Studio Loses Random Chunks of Game Files (scripts, objects, folders, etc) when Roblox site goes offline during live Studio Session

I searched the #platform-feedback forum for anything similar and all I found was issues with the datastore, which isn’t really the same as what I am experiencing. So this might be a rare bug or something completely different, LOL.

This bug report is related to working in Studio when something on the other end of Roblox goes offline (reboot, no Internet, whatever happens out there, etc). The first time this happened, I thought it was my fault. Maybe I hit a delete button by accident somewhere and wiped out an entire folder of models and scripts? But now that it has happened twice and I was able to spot when it happened and make notes, I hope this will help the Roblox engineers narrow down the cause. I did search the bug reports for something similar because I can “respond” to other bug reports in a reply, but no one has put up a detailed enough bug report about this specific error to work with. Ok, enough history, time for evidence.

It just happened again today (yesterday now), only an hour before this posting as I was getting together screenshots and data, doing test to see if I actually lost data, etc. To be more specific, it happened before 8:45 PM Central Time Zone, 8/26/2022

Bug Report:

Details: An Internet interruption of the connection between Roblox and the Studio software can cause Studio to lose random chunks of your game, be it models, folders, code or anything else under the Workspace. No errors will be generated on screen nor will anything show up visually to signal the user that something has happened. You won’t know something is wrong until either you try to test your game and get errors due to missing resources or you close Studio thinking everything is saved and come back later to find random stuff deleted/missing from your game.

Where: Roblox Studio

When: Rare, hard to reproduce

Screenshots: Linked below

Reproduction: Work in Studio and either simulate a link failure or wait for it to happen on Roblox end (rare), random as to what you may lose.

Environment: Windows 7 Pro, 16GB of RAM, no Beta Features enabled in Studio, No Plugins Installed, as raw of a Studio setup as you can get. Studio never crashes or generates errors when this happens.

Studio Version:

–No micro-dumps generated, no crashes of Studio

The links below have pictures that detail the signs of something is wrong in Studio along with further testing that shows Studio did indeed lose data because saving your game results in saving it as though you deleted a bunch of random resources in your game.

Bug Image 1, you can see that Studio is showing that I am missing folders and objects

Bug Image 2, I can plainly see in explorer that the folders, paths and objects do indeed exist, at least in that view. So from the user standpoint, everything is fine and the error makes no sense.

Bug Image 3, I made quick backup of the entire game and compared it to yesterday’s backup. Over 349k of code, objects, etc. are now missing from what is live in the Studio. Not a good sign!

Bug Image 4, If you restart Roblox Studio (remember, it had no errors or warnings before), then you get an error about a disconnected Team Create session, which is probably the source of the data loss? Add to this, I don’t do Team Create sessions with anyone, so it’s odd that it would say that, but it’s the sign that something is wrong though and to look for data loss.


We’ve filled a ticket into our internal database for this issue, and will come back with an update as soon as we have news!

Thanks for the report!


I believe I have encountered this before as well. In my case it seemed to affect only the ParticleEmitters in my place file, for whatever reason.

At some point on our Team Create studio file we lost hundreds of ParticleEmitters from somewhat random locations, though they were all descendants of the Workspace. Many ParticleEmitters still remained, and none of the actual parts that the emitters were parented to were missing.
I ran a script on both files from before and after it happened to get a count of various instance types, and no other instance types were affected - ParticleEmitters in ReplicatedStorage, ServerStorage, etc. were not affected either.


This is what I’ve seen when it happened to me, it affects only the workspace, but the other areas like the Sound Service, ServerScriptService, etc. all appear to be fine, no missing resources. If you are working on some area of your game and don’t visit the other areas because they are “done”, it’s odd when the error comes up in testing because you know that no one has been doing any work in those other areas of the game. The good news, backups can get you back up and running with a simple copy/paste from another Studio session, and even better, the “versions” feature lets you open up an older version in another session and do a quick copy/paste this way if you notice anything missing. The only thing is, doing a look through the resources to look for missing stuff can be time consuming if it’s a big chunk of stuff gone. :face_with_raised_eyebrow:

It happened again today after a Studio update. I lost all of my Spawn locations. Good thing I saved everything before this happened, but as before, I have to spend a lot of time now looking through a recent version and comparing it to what I have now to see what is missing. I would have never known except when I started a play test, my character spawned out in limbo, even though I could see all my spawn locations were still in the explorer view and enabled, but after I shutdown the Studio and reloaded the last save, I could see they were all gone and thus why my character was spawning at default location coordinates due to no actual spawn points. Maybe I never noticed before, but this maybe be related to new versions of the Studio being released while you are still active in your own version?

1 Like

The exact same thing happened to us last night, a folder named “GreenPlaneSpawns” was just missing. We restored it from an older save and just assumed that maybe one of us deleted it by accident, but reading this it seems to line up with what happened. Going to be downloading local copies a whole lot more often now.

I’ve actually seen this happen a BUNCH of times (my wifi goes out, team create doesn’t work, etc.). Even when I just close studio it’s happened. Usually it’s not too bad but sometimes entire scripts are removed, a folder that I copied over (100% as well) is removed, code reverts, etc. This has been happening for well over 6 months to me as well, at first I thought it was just me being tired but as I see this post I realize that it is indeed a Roblox bug that others experience.

I think I found a pattern to this now. It happened right after opening Studio and I only did one thing. Seems that setting a “Boolean” attribute as “off” on a Folder or Object is what makes either that whole folder or object itself disappear while Studio is running, even though you can see it, set it’s properties, etc. Everything appears fine until you run your game and it errors on the missing object(s). It’s still random, I couldn’t reproduce it again, but hopefully it’s a step in the right direction for the dev team when investigating. Thinking back, everything that I’ve lost when this happened all have a “Boolean” attributes on them. The attributes being the one you create in Studio, not via code.

1 Like

Are you still seeing this issue? We have not been able to reproduce this

dude this happend exacly now with me

Are you able to reproduce this reliably? KnightMB had mentioned setting a boolean attribute to false had caused their issue. Was this the same for you?

I have experienced this issue before, the other areas like the Sound Service, ServerScriptService, etc. Seem to be doing alright, no missing resources. But It affects only the workspace. This may only be me but It might as well be for you, I don’t know if you are still experiencing this problem or not. Just saying my side of the problem.

This happens to me every once in a while now. I just spent 30 minutes trying to find out why my script wasn’t working, just to see it completely vanished for no reason. Has happened now in workspace and other places.

Any additional information helps. For anyone experiencing this issue, please answer the following questions

  • Were you in Team Create prior to loosing data?
  • Were there others in the Team Create session with you?
  • Are there others with access to the place you lost data in?
  • Where were the instances that you lost located? (Underneath Workspace, Lighting, etc…)
  • That types of instances did you lose? (Parts, Models, Scripts)
  • What was the top level instance that was lost? (i,e, I lost several parts that were parented to a Model)
  • Do you use Attributes?
  • Were you using Attributes in the instances you lost?

Given we are not able to reproduce this internally, any information that helps us determine a pattern and gives us an idea where to look is invaluable.

Just happened to me for the first time in a while, great knowing that I have to now re-complete commissioned tasks delaying the progress of a project that my payments depend on.

  1. Yes
  2. No
  3. Yes
  4. Workspace, ReplicatedStorage
  5. Parts, Models, Scripts
  6. Lost a massive folder containing attribute-tagged doors in folders
  7. Yes I do use attributes
  8. Unsure about exactly how many of them were using assets, can confirm that the top-level instance that was lost contained many models/parts using attributes

This is a mess, cheers to the next few hours repairing the damaged game. :wave:

I took a break from dev for the last few months for family, but since posting this I have not seen it. I’ll be knee-deep in the studio again soon enough, so if it shows up again, I’ll update this topic and maybe have some better details.

Reviving this thread to check-in. @knightmb1 @oSudden has this issue reoccurred at all since your last posting?

Haven’t seen it to my knowledge.

Has no happened once, which usually by now, I would have posted something here about it. I am certainly curious, at least on the technical level, what the issue was since none us could really put out a step by step reproduction on it due to the randomness of its occurrence. :smiley:

yeah just encountered this today i didnt leave my session until it was fixed tho

everytime i tried to save script edits: