Studio Move/Scale tools - poor performance

Hello developers,

Today I’m posting this thread to raise awareness of a strange performance issue we’re having on this specific place file. Since earlier today, developers I work with are having the issue shown in the mp4 below. We’ve tried removing all of our plugins, but that didn’t do anything. My drivers are up to date. We’ve also tried lowering our Render settings, but that hasn’t fixed it either.

Check the CPU usage when I try Scaling/Moving an object.

Here’s a gif a colleague of mine shared with me of him having the same problem

Do you think that you had the same problem I had?

1 Like

Definitely not. This issue is performance-related, the increment is irrelevant

The reported issue is with Studio tools, but the bug report was filed under Engine Bugs. Does this happen with something in-game too, or only in Studio?

Please make sure to follow all steps listed in How to post a Bug Report as well, such as clarifying whether this is level-specific or happens even in an empty baseplate, enumerating repro steps (e.g. this was originally reported alongside a memory leak caused by a plugin; do I need to wait for this to take effect like the memory leak, or does it happen immediately upon opening a place?), providing a microprofiler dump, etc.

1 Like

I apologize, I chose the wrong category accidentally. It only occurs in studio so I’ve modified it.

This issue seems to be level-specific. If I open a baseplate, I don’t have this same problem. As for the microprofile, here’s what I’ve got. microprofile-20191102-190245.html (584.6 KB)

Since this is level-specific, we will need a repro file in order to investigate. Would you mind PMing me the place you are using?

1 Like

The place’s problem appears to be a Humanoid that was accidentally parented/ungrouped into Workspace:

image

As a general warning to everyone, Humanoids have special rendering and other logic which is more expensive than otherwise. When you make your entire game a Humanoid, bad things happen. We’ll see if there’s anything we can do to prevent this from happening or do a better job of informing developers in Studio when something like this happens.

5 Likes

I see. I didn’t think something so simple would have caused this. Thank you so much for the help, we really appreciate that you’ve taken the time and energy to assist us here <3

Performance is back up again:D