Studio not loading properly

For the past several weeks, this popup keeps showing up that Roblox studio didnt load properly.

If this popup shows, it prevents me from using the asset manager to import assets into the game.

I have to restart studio a couple times to fix it.


Thanks for the report. We’re looking into it

1 Like

This has been really effecting us the last few days. We have to restart studio multiple times and still things will not load.

Material service was really struggling over everything. 5+ restarts to see materials.

View the gray pets


  18:09:42.758  Connecting to server...  -  Studio
  18:09:50.231  You have connected to the server.  -  Studio
  18:10:43.565  Unable to load Workspace.Map.38 | Icy Peaks.PARTS.ForeverDev.LC_TuxedoJacket_Accessory.Handle.SurfaceAppearance - ColorMap 'rbxassetid://9829384694' (Error: HTTP 429 (Too Many Requests)).  -  Studio
  18:10:43.565  Unable to load Workspace.Map.38 | Icy Peaks.PARTS.ForeverDev.LC_TuxedoJacket_Accessory.Handle.SurfaceAppearance - NormalMap 'rbxassetid://9829143869' (Error: HTTP 429 (Too Many Requests)).  -  Studio
  18:10:43.602  Unable to generate 'Workspace.Map.38 | Icy Peaks.PARTS.ForeverDev.LC_TuxedoJacket_Accessory.Handle.SurfaceAppearance' due to some of the textures being unavailable. Change a TextureId property to retry.  -  Studio

In the last couple of hours, anything we’ve tried to upload onto studio has issues loading its textures. Which ranges from either the Normal, Roughness or Metal maps failing to load properly to the entire texture not loading. The mesh that fails to load its texture is random and changes every time studio is relaunched or the model is copy and pasted onto a newer place.

Models with textures that were uploaded days ago do not suffer from this problem. The same model that works fine, if uploaded as of the posting of the message will suffer from the above issue.

The parts marked gray are the parts that failed to load, whenever studio relaunched those same parts may have their textures loaded and others will fail instead.

1 Like

@KizmoTek @chickenputty @SpekuII

Do you think that these issues vary by place? Have you experienced them in multiple places? Have you experienced them in group places and personally owned places?

The problem remains consistent on both group owned and personal places.
The only thing that varies is the mesh piece that fails to load its texture.

In addition to that, the textures may start to load properly at around 2 to 3 days after they’ve been uploaded with some parts continuing to not load.

Here’s the studio logs regarding the failure that my friend was able to obtain.

Not sure, the game I work on with this issue is in one group. It happens on prod & dev place for that game for all team members. In the Top Engaging Discord @ItsKoiske and @RELLvex were having the same issue.

1 Like

This issue happens in multiple experiences but it seems to mainly be happening in experiences where there are lots of stuff that need to load.

It doesnt happen in smaller workspaces.

We found a way to probably resolve the “error loading entries” problem but it will need a code change shipped with the next Studio version.

The texture loading failure is likely unrelated and is still being investigated.


@chickenputty @SpekuII

Is the texture loading issue resolved now?

Yes, I rebooted studio and I see every texture and material. I’ll reach back out if anything changes. Thank you.

1 Like

Hi all,

@tnavarts I had PMed you those rate limit / HTTP errors when I ran the game, but those resolved.

Now when testing the character’s outfit is gray for all of our team. Regardless of the avatar. No studio errors show for this.

Also, when leaving testing all textures in studio have to reload and it takes a long time. They are gray while loading. Eventually everything does load, but it takes a considerable amount of time - more than it used to.

This is also happening while the game is booted too (the pet on the right should be a pink axolotl)


The “Error while loading entities” error should be fixed now. Let me know if you still run into it.

1 Like

If you’re talking about this error, it still happens sometimes.