Studio not registering user as logged in

Pretty self-explanatory based off of the title. I’m logged into Studio, and the toolbox isn’t showing my sets, including My Models. Games on my account aren’t loading, and plugins are returning ‘0’ when attempting to get the logged in user’s Id, which is indicative of Studio not registering me as having logged in.

This is hardly “critical”, but it’s persisted through multiple reloads (and reinstalls) of Studio and I’ve restarted my computer multiple times. As for reproducing it, well, I’ve not found anyone else experiencing this issue. I’m on Windows 8.1, 64 bit.

Pictures, for reference:

Have you tried logging out and back in again?

I’ve had this same thing happen before where studio will log me out but it will still display that I’m still logged in even if I refresh the home page. I found that the above method I mentioned seems to fix the problem of studio thinking you’re logged out.

  • What OS are you on?
  • How did you open Studio?
  • When was the last time you logged in/out?
  • How long was Studio open before you noticed this problem?
  • Mac 10.11.6 (though I’m not sure if it’s happened in this version yet for me)
  • From the dock or launchpad
  • Not sure :confused: I normally just log in and I stay logged in until this happens, studio logs me out when it updates (not sure about this since I don’t log in much and I haven’t taken note of what causes me to need to log in to studio again), or the rare occasion I sign myself out of all other sessions. Basically, logging in/out is rare since I’ll log in and then stay logged in for days (over a week maybe?) because I find no need to log out.
  • Same as the above, sometimes I can have studio run fine for days though some days studio will crash for me multiple times in a day (a separate problem that I believe is linked to smooth terrain) and I normally just minimize studio and it stays running until I restart my computer or studio crashes or the rare occasion that for some reason I want to improve my computer performance slightly by not having studio running in the background (I have an older computer so it helps a little).

The annoying thing is that it’s rare for this to happen so it’s hard to tell if there a pattern or not. However, from what I can remember it does often happen when I’m in the middle of working on something. Like I’ll be building and saving fine and then it just stops and I have to log in and out to be able to save properly.
This next point I’m not quite sure about but I feel like it also seems to happen when I have a place open and I’m working on it and I minimize it for a while or leave my computer for a while and it goes to sleep and then when i come back to keep working on it.

I wish I could give more solid info but as I said before it’s kind of rare so it’s hard for me to even remember the specifics of when it happens :confused:
I hope what info I do have can be of some help and I’ll try and keep an eye out if it happens again and see if I can’t provide some more useful information.

  • Windows 8.1
  • Launcher
  • Every time I launch studio, recently. This may be a related bug, or it may be something different, but I’ve been having to sign in every time studio is launched. This has been going on for about 4 days as of writing this. Prior to this, I had last signed in a few weeks ago.
  • Near instantly; I tried to insert a model into a place, toolbox wasn’t loading my sets.

I tried with a different account to see if it was account specific, and it didn’t seem to work there either.

Still not working, and studio has updated since then. This is a serious issue, and is preventing me from working on things.

Does this happen to you if you launch the place from the website’s Edit button as well?

I’ve tried on Win 8, but after launching Studio and signing in, all the items you reported as missing seem to be fine.

Just now tried it. Yeah, it still happens when I launch it from the Edit button.

Can you send me a video of this happening, as well as the logs from your machine?

So as it turns out launching it from the website seems to have resolved it… Somehow.

It was doing it earlier today, then I launched it from the website, and it worked on the next launch. If I experience it again, I’ll grab a recording of it and my logs and send them your way, but until then… Thanks.

Sounds good. Glad we could at least get you into Studio again!

Annnd now it’s broken again. I’ve sent you stuff related to it.