Studio persistently crashing when attempting to edit a specific game

I noticed on Tuesday that every time I tried to edit one of my specific group games, my studio would crash almost instantly. This has happened 100% of the time I have now tried to edit my groups’ games.


Log file
1571904742.02742,194c,6 Finding AppSettings.xml
1571904742.02742,194c,6 Opening AppSettings.xml
1571904742.02742,194c,6 Parsing AppSettings.xml
1571904742.02742,194c,6 Looking for 'Settings' element in AppSettings.xml
1571904742.02742,194c,6 Looking for 'ContentFolder' element in AppSettings.xml
1571904742.02742,194c,6 Looking for 'BaseUrl' element in AppSettings.xml
1571904742.02742,194c,6 BaseUrl loaded from 'AppSettings.Xml'
1571904742.02742,194c,6 Looking for 'IsScriptAssetUploadEnabled' element in AppSettings.xml
1571904742.02742,194c,6 Looking for 'IsAnimationAssetUploadEnabled' element in AppSettings.xml
1571904742.02742,194c,6 Looking for 'IsImageModelAssetUploadEnabled' element in AppSettings.xml
1571904742.02742,194c,6 Looking for 'CrashMenu' element in AppSettings.xml
1571904742.02742,194c,6 fetchClientSettingDataViaHttps
1571904742.28673,194c,6 LoadClientSettingsFromLocal group: "ClientAppSettings"
1571904742.28773,194c,6 LoadClientSettingsFromLocal group: "StudioAppSettings"
1571904742.28773,194c,6 Studio Version: "0.407.0.353595"
1571904742.28773,194c,6 CrashReporter Start
1571904742.28773,3e0c,6 WatcherThread Started
1571904742.99780,194c,6 Warning: LocalizationTable:DecodeCsv dropped 1 entries with duplicate (key) or (key,source,context) from LocalizationTable
1571904743.01774,194c,6 = en_US
1571904743.04866,194c,6 Studio D3D9 GPU: NVIDIA GeForce GTX 1060 6GB
1571904743.04866,194c,6 Studio D3D9 GPU: Vendor 10de Device 1c03
1571904743.04866,194c,6 Studio D3D9 Driver: nvldumdx.dll
1571904743.04866,194c,6 Info: RobloxMainWindow::RobloxMainWindow - start
1571904743.06861,194c,6 Info: RPC:Constructor Started server - RBX_STUDIO_13356
1571904743.06861,194c,6 StudioABTests using browserTrackerId 45218340184
1571904743.97373,194c,6 setAssetFolder C:/Program Files (x86)/Roblox/Versions/version-616a423b898d40db/content
1571904743.97474,194c,6 Reflection::load C:/Program Files (x86)/Roblox/Versions/version-616a423b898d40db\ReflectionMetadata.xml
1571904744.69027,194c,6 Info: RobloxMainWindow::showNativeLoginPageWidgets
1571904744.69526,194c,6 ======== Studio Startup Times =======
1571904744.69526,194c,6 FastFlagsLoadTime  : 0.2613 sec
1571904744.69526,194c,6 Authenticated : NO
1571904744.69626,194c,6 LoginPageOpenTime  : 2.6766 sec
1571904744.70523,194c,6 Info: RobloxMainWindow::RobloxMainWindow - end
1571904746.73882,194c,6 Info: RobloxMainWindow::createAndShowIDEDoc with task EditPlace
1571904747.42953,194c,6 Info: RobloxIDEDoc::open - start
1571904747.58482,194c,6 Info: 	Locking DataModel
1571904747.59784,194c,6 Info: 	Initializing Ogre
1571904747.59784,194c,6 Info: 	Initializing View
1571904747.66831,194c,6 D3D11 Adapter: NVIDIA GeForce GTX 1060 6GB
1571904747.66831,194c,6 D3D11 Adapter: Vendor 10de Device 1c03 VRAM 6052 RAM 8161
1571904747.66831,194c,6 Caps: ThreadSafe 0 Framebuffer 1 FpFramebuffer 1 Shaders 1 Compute 1 Instancing 1 ConstBuffers 1
1571904747.66831,194c,6 Caps: Framebuffer: MRT 8 MSAA 8 Stencil 1
1571904747.66831,194c,6 Caps: Framebuffer: Depth16 1 Depth24 1 DepthFloat 1 DepthClamp 1
1571904747.66831,194c,6 Caps: Texture: RGB10A2 1 RG11B10F 1
1571904747.66831,194c,6 Caps: Texture: DXT 1 PVR 0 ETC1 0 ETC2 0 Half 1
1571904747.66831,194c,6 Caps: Texture: 3D 1 Array 1 Depth 1 MSAA 1 MSAAFP16 0
1571904747.66831,194c,6 Caps: Texture: NPOT 1 PartialMips 1 CubeMipGen 1, CubeFramebuffer 1
1571904747.66831,194c,6 Caps: Texture: Size 16384 Units 16
1571904747.66831,194c,6 Caps: ConstantBufferSize 65536
1571904747.66831,194c,6 Caps: 32bIdx 1
1571904747.66831,194c,6 Caps: ColorBGR 0 HalfPixelOffset 0 RTFlip 0 MinusOneToOneDepth 0
1571904747.68527,194c,6 Video memory size: 2147483648
1571904747.69524,194c,6 Loaded 281 shaders from pack d3d11 variant default (1080756 bytes)
1571904747.69524,194c,6 Compiled 281 shaders in 9 ms
1571904747.72370,194c,6 Info: 	Initializing Explorer
1571904747.72370,194c,6 Info: 		RobloxViewStudio::RobloxViewStudio - start
1571904747.72370,194c,6 Info: 			Marshaller
1571904747.72370,194c,6 Info: 			BindToWorkspace
1571904747.72370,194c,6 Info: 		RobloxView::RobloxView - end
1571904747.72370,194c,6 Info: 		RenderScheduler::RenderScheduler - start
1571904747.72370,194c,6 Info: 			Marshaller
1571904747.72370,194c,6 Info: 			BindToWorkspace
1571904748.59998,194c,6 Info: 			ConfigureStats
1571904748.59998,194c,6 Info: 			RenderJobCyclic
1571904748.72153,194c,6 Info: 	Loading File : 
1571904749.00379,194c,6 Info: 	Open Success
1571904749.47852,194c,6 Info: RobloxIDEDoc::openPlaceSessionConfigWithStream - end
1571904749.49647,194c,6 Info: RobloxIDEDoc::activate - start
1571904749.49847,194c,6 Info: RobloxMainWindow::showTabWidgets
1571904749.98467,3018,6 Info: DataModel Loading
1571904751.66162,3e0c,6 Info: StartProcessException...
1571904759.36764,3e0c,6 Info: Uploading crash analytics...
1571904759.36865,3e0c,6 Info: Done uploading crash analytics
1571904759.37368,3e0c,6 Info: WatcherThread Exiting.
1571904759.37469,3018,8 Open: Web (0)

I have currently tried.

  1. Restarting my PC
  2. Reinstalling Roblox and Studio
  3. Attempt to edit the game with a different PC
  4. Attempt to edit the game with an alternative account
  5. Attempt to edit the game in a Windows 10 Virtual Machine
  6. Attempt to edit a saved .rblx file of the game (both online and offline)

from my own assumptions, the only reason I can’t edit the games is, that there is a script in ReplicatedFirst with a Unicode character name (Which I do not remember anymore).

Currently, I’m quite desperate to get this resolved as those games have completely been broken down by the latest Roblox update causing everyone to get kicked from the games, and as I cannot even edit the games I simply cannot fix it or figure out the cause of it.


Are other developers able to access it?

1 Like

Not sure if this is related or not, but loading other games and places for me is extremely slow.

EDIT: I tried opening a place and it too just crashed.

No, not the ones I trust at least.

1 Like

Make a new place and create a script with a Unicode character name and see if you can reproduce the issue at all.

I’m getting the same problem whilst editing games with similar conditions.

Along with that I’m noticing that Roblox has been strangely slow today (on both the Games page and on studio with multiple connection errors on Team Create). Could this be related?

I’ve tried multiple things such as closing all of my tool panels on studio, only to have no luck with fixing the problem.

1 Like

I wasn’t exactly able to replicate the exact crash that I have with what I mentioned before, but I noticed that large folds inside a script will crash the studio.

I was able to create a game with a script inside the ReplicatedFirst, which will crash the studio with the large folds method if opened. While testing this with couple of people, about 2 out of 3 crashed.

I’m not quite sure, but the issue itself might be the folds instead of the Unicode characters.


Hi OssieNoMae, thanks for reporting! We are investigating the issue. I’ll keep you posted.


We just had some internal discussion of your crash cases…

It seems to be caused by the analyzing/parsing scripts after loading the game. And good news is that we are going to release a new script analyzer & parser, which hopefully can avoid the issue:-)


What timescale are you working with, if I may ask? I would like to notify my community, when the possible fix could be done.

You know, this feature will be released by other teams, so far I don’t know the exact plan, sorry about that:-)
I will let you know as soon as I get more info.

Maybe next week, not 100 percent sure, please check the next week release to see if works or not:-) Then let me know, I can help you double check then.


I’m still getting the same issue, even after today’s update.

Update: Seems like it actually worked after testing it again. The load times seem quite slow, but it works!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.