Studio testing takes a long time to stop without errors or warnings

since yesterday 1/31 when stopping a studio play session, it can take anywhere form 30 seconds to much more, even a couple minutes to stop the session. This behavior is sudden for me starting at 1/31 and I have not made any modification to my game from a state where this long delay did not happen.

I suspect it might have something to do with BindToClose on my data store code (which has worked find and has not been changed in months), but without any warnings or errors I cannot diagnose anything.

It takes so long and I have no way of knowing why, it is reducing my productivity by a large amount.

3 Likes

This has happened to me before, It seems like a memory leak or just a randomly occurring thing, My game that used to take 5 seconds to load/join now takes a minute sometimes, I think it comes down to the amount of HTTPS request

without errors or warnings, its just a mystery. And It started happening suddenly while i had not made any modifications tot he game when before it worked fine.

I have reinstalled studio, I have removed nearly all plugins im using. I have turned off ALL plugins to test and yet this shutdown is so long I can get any work done today. It does eventually shut down but after 2-3 minutes.

I tried using the server testing mode in Studio with multiple players, when they leave a game, the server out shows the disconnection happening at the normal rapid pace I am used to.

Not sure what going on in Studio Play

Have you tried shutting down programs that may be using the CPU?

Any program can take time depending on if your CPU is putting the program on hold.

Do CTRL + Alt + del and click Task Manager, click More Details, Click on CPU on the top, and close any program you probably don’t use or aren’t using right now.

If this still doesn’t work, I’d highly recommend these below, do them from top to bottom.

Go in the game, replace any ‘while true do’ to 'while game:GetService(“RunService”).Heartbeat:Wait() do’

Make sure you put waits on some of your scripts and check the console for any errors.

Turn off windows 10 Game mode

Invest and buy a new CPU and buy a SSD

I thought this was only me, guess not, I’ve been noticing this for weeks to months now, though it only happens sometimes, it’s still really annoying. I originally thought it was computer being slow, but when I tried to close the game session again, I noticed that memory usage spiked and studio just crashed, which never happened. The most shocking thing in my opinion is that this is a testing game with low script activity and no assets in the workspace

Huh, That is odd and I’ve never seen that happen and Studio doesn’t take that much memory so I’m highly suprised.

How much memory does your computer have?

My computer has around 15.8 gigs of usable memory

yes I restarted my PC (which is MORE than capable of running studio and most games at max settings) so no apps were running. I have a total of 4 hard drive and my operating is running off of my fastest SSD.

I’m not sure I want to go into my code yet and make changes like you suggest. Everything was workign just fine up until yesterday morning and I already rolled back any code I changed since that point and it still does it. So what I am saying is my code has been running fine for months, now suddenly studio take forever to close Play testing.

Well, I have spent the ENTIRE day on this!

I have disabled ALL code in my game, including modules being required.

There is no code running in my game whatsoever and it still take over 1 minute to end studio play test.

I really need help to understand what is going on with this. As it is, I spend over 10% of my workday waiting for studio play test to close while testing various parts of code. If use studio play test 30 times in one day, thats a full hour of my day waiting for it to close!

This happens consistently on several machines and for different people who are also working on the game. It does not happen to all places I own, but it happens to this one that I am actively working on. I have tried to publish the place into another place, and the issue persists.

As I said above, I have at one point disabled all running code in the game and this problem persists. I have rebooted my PC, made sure there are no other app running. I have re-installed studio. I have removed assets we don’t immediately need.

I question my ability to even finish my game at this point. Feeling stressed, need help! Thank you :slight_smile:

EDIT: on a positive note, I have been squeezing in a few sets of pushups while waiting for it to close!

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

4 Likes

@Planet_Dad are you still experiencing this issue. Does this also happen on a new empty project?

1 Like

Yes I still experience this issue and I cannot use Play or Play Here to test my game for months now without having to wait a long time for close. While wait times to close the session used to be upwards of 5 minutes, they are now lower and sometimes happen in about 30-45 seconds, but sometimes longer.

It is far faster for me to your Studio Server Test, that starts up and closes much more reliably, the only issue is missing the Play Here so I can get places quickly.

It does not happen on all game I own, just a few of them.

1 Like

I have also been experiencing this issue for the last couple of days. I have tried uninstalling Studio multiple times and it does not seem to be helping. It would seem other players are having this same issue too.

2 Likes

Thanks again for the report. I found the ticket we filed internally and there are reproduction steps for what may be the same issue. According to the repro steps, this can happen if a plugin calls BindToClose() and then wait(). It’s unclear to me if this is the same issue you are experiencing or when we will get to fixing the issue we reproduced ourselves.

In the meantime:

I saw you tried disabling/uninstalling all plugins. Did you also delete the plugins in your local plugin folder?

I’d also suggest removing the contents of all your BindToClose calls and then, if this resolves the issue, incrementally add the content back in until you hit the delay to help identify which line of code is causing the slowdown (if it is indeed due to BIndToClose like you suspect).

3 Likes

I Am also having this issue, I disabled my Soft shutdown script but it still is occurring what’s going on?

1 Like

I get the same issue when I remove my scripts. May be a cache issue.

For the OP, I honestly don’t know what the problem could be, and game:BindToClose only checks if the game is shutting down or not, it’s weird that that function call would slow your game down.

1 Like

Yeah it still happens to me. I have tried so many things but as crazy as it sounds, I have come to accept that Studio is what it is. I no longer use Play or Play Here to test, I only use Studio Server testing and while it take longer to load and east up my time, that’s been my life for months now.

1 Like

I’ve been having this issue around the same time as you all, it consumes so much of development time and decreases productivity. I disabled all plugins and scripts to see if it would repeat and it sure did.

Still having this issue even at the time of writing, ROBLOX Support has been completely useless when it comes to assistance with this.

EDIT 1: While searching around DevForum I found out that people have been reporting that the FastCast module is causing such long loading/re-loading times (because it uses a lot of the advanced new Luau features). I just removed it and the issue has been fixed.

2 Likes