Studio using more CPU than it should be

I opened a fresh studio instance with just a baseplate, and somehow its using 12.9% of my cpu, it’s not much, but it adds up with multiple studios open. If you’re wondering, that is about half a core on my i7-4790k

I’ve only started to notice it recently, but I know it never used to use this much cpu.

Yes, I disabled all plugins as well.

System information
Windows 10 64bit
AMD HD 7770

on a side note, all studios use around the same amount, even if one has a ton more things in it.
Here is an image, I highlighted the one with the baseplate.


I seem to be seeing the same thing. A blank baseplate withe studio minimized is showing around 25% cpu usage. That’s about equivalent to what photoshop uses while painting on a large canvas.

Window 10 64bit
amd radeon hd 6870
amd fx-4100 4-core @ 3.6ghz

I’m getting this too. Around 16% usage here on a blank baseplate.

The Boulder has observed an Empty Baseplate on Windows 10 3.9 GHz 4-core AMD A8-6600K APU:

Using up an entire core on an empty baseplate… i5

I was wondering why my fans were spooling up so much…

1 Like

When I hear them get louder I just assume they’re doing a fantastic job.

1 Like

This issue was fixed with tonights update.

1 Like

ROBLOX Studio updated, but…

Is this update supposed to already be out?

Still appears to be an issue after the update. I also notice cpu usage doesn’t go down after closing the place, but not studio. Also tried disabled all plugins with no effect.

1 Like

Weird… it was fixed for me, I guess not.

I see it too, post-update. Open any place in Studio and one core is maxed out. Start the server and the other core is maxed out. When I start a client it is pretty much unplayable ( I knew I should have sprung for a 3-core CPU).

Doesn’t happen on gametest3.

1 Like

My guess is the issue where Roblox wouldn’t load on single core CPUs is back-firing on use (people with multicore processors).

Ayy we have the same graphics card bro

But yes, same problems here. Still not fixed for me.

We’re investigating this issue.


For me I’m getting high CPU utilisation, but not really on just one core.

Maybe you could say Core 1, but it isn’t as obvious as @TheNexusAvenger’s

After I closed Studio, all cores had their utilisation decrease.

Any word on this?

We’re working on a fix for this and we’ll get it out ASAP.


Any more news on this?

1 Like

Fixed for me with today’s update. Thank you!

Yup looks like it’s fixed as of this morning :smiley: