Studio wont save project because of symbolic link

Can you rephrase that is it that you said they updated it and is now fixed?

Or your asking if they fixed it with new update? It seems like it comes and goes so I’ll have to see if it fixed.

1 Like

Staff note: this post is from Feb 1 and was merged in later

I’m making a small script game, just making a basic food system, and whenever I try to publish it this shows up in the output:
It won’t even let me save, I need to wait till it autosaves, open up the autosave from the autosaves folder, then publish to the game from there if I want to finish it up.
It’s only this game, and I don’t know why. I’d really appreciate some help on this.

Not on team create,
Game link: Food System - Roblox
Bug generally happens when game has been opened for too long in studio.
Will get full log file next time bug happens, most likely soon.

EDIT: After several attempts, the bug has not happened again, probably was a temporary roblox bug.

Staff note: this post is from Feb 1 and was merged in later

I’ve been recently been working on a game in roblox studio, after around 1-2 hour(s) I tried to manually publish the game and received a window stating an error saying “Failed to publish. Please try again later” and I noticed another error in the output another error saying “Get symbolic links failed with error: Authorization has been denied for this request.”

Is there anything I could possibly do to prevent losing the current progress?


Staff note: this post is from Feb 14 and was merged in later

I’m getting errors left and right, and all right after a massive amount of building I did. I have no idea what caused it but it started with “Get symbolic links failed with error: Authorization has been denied for this request.”
Luckily I can still save it to file. :sweat:
I started looking for reasons, even undid most of the progress I had made before attempting to publish.
Only to be followed by game setting errors and API request failures!
Even animations. :sob:

Sorry in advance for being so vague but there seems to be no reason for all this happening.

1 Like

Staff note: this post is from Jan 31 and was merged in later

(First of all, If this isn’t the right place to post this my bad.)

So whenever i try to turn on teamcreate, save or publish (Maybe theres more)
I get “Get symbolic links failed with error: Authorization has been denied for this request.” in the output.

It keeps happening, Now i can’t exit studio because otherwise i will lose my progress.

The bug seems to happen to my game only, Since i tried publishing on a diffrent game and it published.

It started happening when i clicked the teamcreate button, And i don’t know what’s going on.

Sorry, these were all temporary service outages and should no longer be an issue. Our engineers are working on making sure this doesn’t happen again.


Alright, Good to know, When i first saw it i was scared i’d lose my progress.
Glad to hear this won’t happen again!

so all of these are from the outages from roblox’s servers?

Correct. When this happens, you may encounter a number of other problems like the website failing to load, being unable to log into Studio, etc, but it seems in these cases you all encountered this particular error first.

1 Like

Do you have any clue why their servers keep going down or do you not have that info?

i heard its been happening every so often in the past few weeks and now.

Because they have a big platform with tons of users online at any time, and maintaining an architecture as big as they do is very difficult and involved, especially because Roblox is still growing very quickly. Not sure what kind of answer you are looking for – technical details on their cloud deployment are not useful to developers because we don’t interact directly with the underlying architecture.


At least a reason of it going down technical is helpful. because people could of complained that the servers are trash.
Which they are not and people that i have heard are speculating that roblox is getting hacked which isn’t the case more likely.

Am i thinking this wrong?

This is all the information you should need:

Respectfully, based on the way you are discussing, I think that will be enough explanation and any further technical details may just be confusing to you. The community does not have the technical know-how to meaningfully comment on it.


Ah thanks for the reply its very helpful and i couldn’t find that so Thanks you Very much. :+1:

I seem to be experiencing this as well, and I’m aware that this is a Roblox-end issue.

The reason I’m replying to this thread is because I am experiencing this behaviour only in one of my studio projects. Concurrently, I can save the rest of my projects, but one of them throws this symbolic link error. If it is a Roblox-end issue, why am I experiencing both saving and link errors simultaneously?

I think it’s also worth noting that I was able to save the project yesterday, and I haven’t closed it since last night.


Apparently, after investigating some more, I realized that I could not login to Roblox via the main site - I was moderated for having uploaded an “inappropriate” image (it was a semi-circle…).

That still doesn’t explain why I was able to open other places (and save them) but at least the problem is fixed now.

Really, a semi-circle… Is that a foreign object or something?!

Same here. I’m having the same problem and I’m about to lose all my progress if studio doesn’t budge

Oh man, now it’s not even letting me use studio. I’m logged out and can’t log back in. This has escalated into a [ROBLOX-CRITICAL].

Is anyone else having this problem? This is a very big issue.

I might not know the saving issue and haven’t had this issue when you posted, but from me I think roblox was down during that time and was not saving. I’d recommend to download you’re place to keep what you saved and if it’s back up online to publish the file you saved.

I used DownDetector and I think this is pacific time zone.

Edit: Do you happen to have Team Create on on that place?

Happening to me now

I’ve recently having this issue today

So this is happening to me, it says NIL USER