UI Images resetting when changed

The image stays to what I set just fine when I initally change it from the Roblox default image. However whenever I try to change the same ImageLabel to another image, it resets back to the first image after usually around 3 minutes. It also resets every time I go into play mode and stop. The same thing occurs if I clear the image completely so it’s blank. It just resets to the first image that I set.

This has been happening for over a year now, as long as I remember. Though it wasn’t as bad at first, it usually worked fine after setting it twice or restarting studio. It gradually got worse overtime.

I’m probably the only one experiencing this bug as it’s pretty severe (literally doesn’t allow me to create UIs) yet I couldn’t find any post about it.

This has been happening on a laptop I previously owned & it still happens on my new PC. It occurs on any game in studio.

Please do let me know if this is in the wrong category, if you have any possible solutions, or if you need any info/specs.



Is this in Team Create?

1 Like

Yes, and now that I think about it I’ve been working in team create enabled games for over a year now…

1 Like

When this happens, is the connection indicator in the top-right of the screen red?

1 Like

Yeah, overall connection is pretty stable; only disconnect from studio or crash once or twice a month.

I actually had this issue as well, it occurred for me when I uploaded an image through the image label the first time, and then replacing that with an ID from a different image label or a decal. I had to delete the original image label, make a new one, and copy the ID in first or upload the correct image directly. That seemed to fix the problem.

1 Like

That does somewhat fix the issue as the first image you set works just fine, but it’s a very inconvenient workaround, when the UI itself is done, since you have to resize and reposition the new imagelabel.

1 Like

Exactly, I was looking to write a bug report about it but I’ve been very busy, I don’t feel like writing another Post Approval topic.

It’s annoying but at least the workaround isn’t too hacky, no need for weird scripting shenanigans.

1 Like

So no you did not have a red connection indicator, and it was green like it normally is?

@tralalah was this also in Team Create? Did you have a red connection indicator when this happened?

This was not in Team Create, and actually I don’t even have that indicator on my screen (I’m guessing that’s from a Team Create session?)

How quickly did you change the image to a new one after uploading it through the Properties file picker for the first time?

I think that’s actually what’s at the heart of this issue - I noticed that the game explorer doesn’t always have the images I uploaded through the properties file picker. I’ll try to retrace my steps on a baseplate with a simple image to clarify what I mean.

Update: I’ll outline what steps I did to try and reproduce this behaviour. I ran into some different behaviour than what I initially experienced; I will comment on this below, @Subcritical_alt

  1. Created a brand-new baseplate, published before adding anything in.
  2. Made a ScreenGUI, added an ImageLabel under it
  3. I tried to upload a png of a circle that I previously had no issues uploading, but right away I was warned for inappropriate content and so it did not upload. FYI, this image is already uploaded to my library on Roblox.
  4. I instead uploaded a png of a semi-circle, which uploaded fine.
  5. I created a part in the workspace and added a decal to it.
  6. I uploaded a texture to the decal, the same circle I tried using in step 3. It too had been flagged for inappropriate content, so I uploaded the same circle, but with a solid background. That one uploaded fine.
  7. I did this fairly quickly, and to my surprise, both ended up showing in the game explorer under “Images”. So it seems the game is working properly. I then copied the image ID from the decal to the ImageLabel, it had no issues showing the image on-screen.
  8. I ran the game and it worked fine. I switched the ImageLabel image back to the semi-circle, and it too ran as expected. I even uploaded a third image, a semi-circle oriented differently (which got me moderated a week ago for inappropriate content), and even that worked perfectly fine. All three images were shown in the game explorer tab, and even on trying to upload new images to either the decal or the ImageLabel, all three show up as options.

So it seems as though the problem isn’t occurring for me anymore. However I wanted to note something important regarding to the flags and warnings I received.

When I experienced this issue last week, I was uploading these very images I used just now. I was working with spliced circles to achieve rounded GUIs that I could customize. The problem was that I was having issues uploading them - I wasn’t notified that they were rejected for inappropriate content. But it gets weirder, because I could upload those rejected images through a decal instead, and through a different game that I made to test out the issue. However, those images wouldn’t show up in the game explorer tab under “Images”, meaning they weren’t part of the game yet.

But they still appeared on the decals during runtime. So I figured there must be a moderation issue at play, in my case. It seems like the filter flags things inconsistently. After uploading the rejected images through the decal, I copied the ID and put it into the ImageLabel, and the image showed up as expected. But when I ran the program, only the decal showed the image.

In the other game I mentioned, all of the images loaded fine, and studio was behaving normally. Eventually I realized that in the original game I was working in, I could no longer save my progress, and autosave wasn’t being called, either. I later found out that I was moderated and logged out of my account, yet somehow I was still able to save my progress in the new game I created.

In other words, I think one of my games slipped through a bypass filter that it shouldn’t have. I noted this in a previous reply to an existing post. I’m not sure if it is related to the ImageLabel issue here, but I did experience them at the same time.

The difference between the behaviour now and a week ago is how the game explorer behaved when I could upload a recently flagged image into a different object. Again, they were just circles and semicircles, although they appear stretched due to the aspect ratio changing on the website (my brother later noted that it’s probably for that reason they were flagged).

But now I am experiencing flags for images I already uploaded - surely there is some inconsistency in the process for flagging images - I think that’s what caused this behaviour in the first place. But it’s good to note that at least the decals now don’t upload previously rejected images, which is why I can’t replicate the problem.

1 Like

Sorry misread the question; it stays green like normal. Though going into play mode and stopping also causes this issue, except not in a certain amount of time, but as soon as I click stop. But this temporarily makes the connection indicator grey while it loads.

Found another case of where it happens; when going to publish the game. Since I can do this in a few seconds I was able to record a gif of it (don’t have a video recording software for a longer video).


This happens 100% of the time no matter what I do

1 Like

Just for reference, this is a duplicate of

Hello, we have experienced this too! I had to delete the instances and recreate them to make it work. It happens sporadically though.

1 Like

I cant speak to the issue within team create iteslf, however a similar issue arises in solo-edit sessions as well that seems to be a memory issue of some kind. The image will appear to be the old file, until published or otherwise updated, where in the correct image is shown. The bug seems especially purvasive when replaceing older versions of an image file with newly updated/uploaded files with the same name.

1 Like

The bug is being fixed by Roblox staff, so far the best workaround is to “close and reopen the place after changing the ID to an asset link.”