Sun reflection still shows when Sky.CelestialBodiesShown is false

If a game has a custom skybox (Sky object under Lighting) with CelestialBodiesShown disabled, sun specular reflections/bloom still show on parts. It would make sense for sun reflections to be hidden when the sun is hidden, right?

My lighting and skybox settings


This bug occurs on all 4 lighting Technologies (Compatability, Voxel, ShadowMap, and Future).

When Lighting.EnvironmentSpecularScale is set to 1, it becomes even worse, and has a Neon material effect around the sun glare, even though the part’s material is Metal.


Agreed that it would be more intutive if CelestialBodiesShown controlled direct sunlight that hits the 3D world. However right now it is intended to directly control whether the sun’s image is rendered in the sky independent of the amount of light the world receives.

I recommend setting Lighting.Brightness to 0. This will disable direct lighting from the sun. If your world looks too dark after this, try increasing Lighting.ExposureCompensation.


I have tried setting Lighing.Brightness to 0, but that also removes ShadowMap shadows. For now I’m using Bloom with Intensity set to 0, which also removes Neon glow. Maybe a new Sky.CelestialBodyReflections property would help, but the roadmap says skyboxes are going to get new features later this year. I’m sure more settings for this type of thing will come with that.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.