Surface gui invisible

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!

Fix the guis so they dont dissapear
2. What is the issue? Include screenshots / videos if possible!

So the surface guis are visible but when i turn 360 degrees as shown in the video it just dissapears. The funfact is that the gui is showing that visible property is checked

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

Yes i did was’nt able to find any…

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

So it just disspears in this game when i make a new game and paste these screens they work just fine

Please help i am trying to fix it for a few hours now

I don’t know why but in other games it works fine.

Try using adornees or setting the “Always on top” property to true

adornee is set and it is correct also the “Always on top” property doesnt work

It could be the ZIndez of the SurfaceGui or the child of the SurfaceGui. It also might be with the graphics quality. If you have several SurfaceGuis on there, thats probably the problem. This is probably due to SurfaceGuis fighting over which one is at the top.

oh yeah i have 3 surface guis but only 1 of them is enabled? does that change anything? this is a screenshot:
image
the “ScreenGui” one is the one which is enabled

also i found out if i turn of the "AutoLocalize Property and turn it back on it just appears look:

I see that you have alot of canvasgroups. Try turning all of them off except for one and see if that singular one doesnt become invis.

yeah all of them are are off (group transparency 1) but that still doesnt cut it :confused:

Hmm. Try going to settings in Studio (file - options) and click rendering. You can try doing something in there. But i think Editor Quality Level should maybe be the fix? Try setting that to 21. And if it works increment it down by a bit till its at the lowest number it can be before the bug reappears (for performance)

i mean the bug appears in the normal game too

Try turning off “ClipDescendants” in the surface gui’s properties, might be the issue.

Did it work? (char limit)
(char limit)

didnt work you mean on the current gui right?

nope it didnt char char char char char

Are there multiple surface guis on the screen? If so, you might want to change the Zindex behavior from sibling to global and increase it.

okay so it seems that i copied the screen from version where it wasnt broken and pasted it into the current version and it still didnt work

okay so it seems that i copied the screen from version where it wasnt broken and pasted it into the current version and it still didnt work …