SurfaceGui's (?) Causing Thousands of OGRE Errors

I’m not positive if it was caused by SurfaceGui’s (yes, they were recently shipped!) but I was just messing with them in another place. Soon after these errors began. It prevents me from moving my camera (last screen render is frozen) Thousands of errors (like below) are being sent every few seconds.

After error
Working -
Toolbar buttons (buttons for plugins, play & stop, etc)

Not working -
Anything that involves the screen. Cannot pull up stats (Tools > Stats)
I’ll edit the post if I can find any more info.

After closing the place, I received a MVC++ Runtime Library error.

1 Like

I’ll need a repro on this one. What you were doing exactly, what place, etc.
Also, could you please go to C:\Users<your profile>\AppData\Local\Roblox\logs\ and get the graphics log file for the crash? Its name looks like this: log_12b34gfx_d3d.txt .


You didn’t know?

It probably is, I’ve noticed some visual errors also.

Well, the SG right now are really buggy but they are fun to play with until you’ve reached their limit.

Can’t wait for updates!

I have got mostly same error as that 2 times and it was not caused by the SurfaceGui (It did not exist on the public site).

[quote] ROBLOX USES OGRE!? [/quote]It’s all OGRE

So what’s exactly buggy in SGs?

You can’t really access them via script I’ve tried couple of different ways but nothing works, then the sizing only works for offset.

You’re going to have to be more specific here. What have you tried, what have happened, what was the expected result?

I have done when the mouse hovers over an object that has a Surface Gui it gets the Surface gui’s children and it prints the names.

Output: nothing.

I’ve tried to make it output so that each line in the code it prints something and it works until it prints the names of the children.

I don’t know, this works for me:

[code]local function recurse§
local ch = p:GetChildren()
for k,v in pairs(ch) do
for k,v in pairs(ch) do


For me, it properly lists all children, including the SG object and its UI elements.

Max, one error I noticed which has also appeared in usual GUIs is Borders, they don’t seem to size correctly. For example, I have two guis, both of size 50x50 offset, yet one is displayed as 51x51 and the other 49x49, no idea why.
Z Index is being funny, It seems that certain objects are automatically displayed infront of others.

I’m just bumping this old thread to let you know that this bug has just happened to me as well…
Since you guys are in need for more info about this, let me explain you how I got this :

I had two roblox windows open (One of them was a tools->test->play solo). I was using a program in another window, then when I came back to roblox, those error mesages kept flooding my output in both windows. I was not messing up with surface GUI’s, I was just designing some UI for my game in a place that has no bricks in it, so it’s confirmed that this problem does not come from surface guis. I halso had the MVC++ errors after closing the windows. Attached to this messages are all the logs Roblox generated in the past 2 hours. I hope this’ll help :wink:

False, OGRE is only related to rendering.