Tampering with Client - Error


I’m having an urgent problem with my game. When my players try to join they are greeted with this message.
"You were kicked from this game: Tampering with Client [read r0001]

I tried looking this error up but I couldn’t find anything about it. I haven’t updated the game and before it was doing just fine, so I don’t know what caused this.

If someone knows anything about this then that would be great.

Thanks in advance,

Do you have any scripts that could have anti-exploit features?

Have you tried joining yourself?

I have tried joining myself and I could enter. I have some anti Exploit scripts but they would only do something about speed & health exploits, but I didn’t change them and they worked fine before.

Try disabling them and see what happens. Also try running a local server in studio (not to be mistaken with play solo!) as you may be able to emulate behaviour for a normal player.

You can then try other debugging techniques to see what’s going on.

It’s not a User-Generated Kick Message

This should probably be brought up to Roblox Staff as a bug
@KingBr1ck Ask a Top Contributor to move this to Bug Reports

I disabled the admin (adonis) and that seems to have fixed it, I don’t know what is wrong with the script tho it worked fine before.

1 Like

Oh, actually I might know about this

@Sceleratis To do with the new security update?

1 Like

A friend just notified that he got kicked out of another game with same error, not quite sure what that caused this.

EDIT: happened again

For me it was the admin that caused it, I disabled it and moved it to storage and that seemed to have fixed it for me.

All kick messages I’ve seen on the client related to the actual built in exploit prevention of the client are just “This game has shutdown” messages. Giving someone who’s tampering with the client a string to go off of, especially a specific one like “read r001” allows them to easily look it up and find what function is causing them to get kicked.


I’ve experienced this with some other games. Previous users who exploited on my game get this, and I’m working hard to see what’s going on.

This was my fault and was fixed earlier today.