Team Create Group games publishing does not save any scripts

I wrote the scripts for this game last week and published it (it does says that my place was published successfully).

When I tested the game on the web page. Everything prints out “Hello world!”, I thought that it’s probably still being loaded.
So one week later, I rejoined and it’s still the same thing. So I opened Studio, created some more scripts and published the game again…

None of the scripts were published!?

Have you tried Disabling Team Create then Publishing as a place?

Scrips will only publish the version since it was last opened i.e if you are editing a script and then publish without closing the script any changes you made will not be published. If you simply close the script the changes will publish. To reopen the scripts you have just closed do ctrl + shift + t for as many scripts as you closed.

I tried closing all the script windows but it still does not save any scripts at all.

Did you then publish the game after closing the scripts?

y e s o f c o u r s e i d i d

I found a solution to this:

Credit: Team Create | Roblox Creator Documentation

1 Like

There was this thing I noticed a while back while using team create, it was called drafts, you have to go to view and select the script drafts and commit changes. Hopefully this solves your problem.