[Team Create] - I can not seem to open my game via Team Create with my development team

My team of developers and I are trying to work on our game together in Team-Create mode. We have had no problems with the feature up until today. Usually everyday we get on together with no problems and work on the game together.

Today my colleague and I tried entering our game from Studio and it kept saying,
“Unable to open the place. Please restart your application and try again. If you continue to encounter this error, please contact customer service.”

I restarted studio several times and I was still getting the same message. Both my friend and I kept getting the same error, but on some occasions when we both attempted to get into the game, one of us would get in to the game and one of us would still encounter the error message. The bottom line is that we both could not get into our game via Team-Create.

I know it says that I should contact customer service if I keep encountering this error but I thought this would be a great place to ask the ROBLOX staff to help resolve this issue.

Hopefully someone can help me figure this out. Thank you.

TEAM CREATE LINK: Ultimate Showdown - Roblox


Having the same issue


Thanks for bringing this to our attention. This bug is a high priority issue, and we are currently working on a fix. I will keep this thread updated with our progress.


Just felt like inputting that this is starting to occur with my group games as well (over the past two days). It usually takes trying to join the game about 4-5 times before I am actually successful in loading the studio server up.

Doing the same thing with me, I wonder does it have to do anything with the beta program?

@IcyTides image
After myself and my development partner tried to group a model studio completely corrupted, it made two copies of the same model but one was empty and one had the model, I deleted the empty one and then it deletes the model for him on his screen, we both restarted studio and now I’m continuously being blocked from entering the game, this is incredibly infuriating and I hope gets fixed asap. He has downloaded a copy of the place file and I can still access that but Team Create is forcing me to not enter the place itself. (My account owns the place)


I am currently having the same issue, went to enable Team Create on a game that I own, and it completely broke it.


I then tried doing the same process again on another game I created, with the game breaking when after enabling Team Create. When I attempt to enabled Team Create, the game saves, closes and does it’s normal thing up until I get to the “Loading game” point.


When I get to “Loading game”, Studio hangs and gets stuck there until I click the cancel button or close Studio completely. Would be much appreciated if this is looked into so I can resume development.


There is actually a solution for this that has worked for me, It’s a workaround for now. Can't connect to new TC places - #4 by cloakedyoshi

This issue should be resolved for now. Please let me know if it isn’t.



Thank you for the quick fix, I can confirm that the places that were previously moderated are able to be opened with no problems now.

Hello, my friend is currently unable to join our teamcreate place and is receiving the same error message as the one shown by the original poster.

It’s happening again.


1 Like

Hey, i’m experiencing the same issues. The error:
The universe id:
I could not post this on #bug-reports because i’m a member


Same for me…:frowning: I was going to do a collaboration but…

Same issue for me. Had it for a few days now.

its still not fixed , very nice roblox!

1 Like

I can’t even turn off TeamCreate via the develop API. It just says that authorization has been denied.

Well we can’t join team create or play a game properly because of the technical difficulty message…

I have the exact same problem. I can’t work on my project that is supposed to release at 1pm (CET):

1 Like

Same my game was set to be released tomorrow. Well it’s not gonna happen then…