Team Create only publishes when it wants to

I’ve been trying to get my game to publish for almost 10 minutes and it’s not working.

I’m using Team Create on Windows 10, I have a stable internet connection.
All it says is “Sent message to server to publish” and then nothing happens when I check in the Version History.

I’ve probably pressed the publish button about 50 times, and nothing has updated in the game.
I’ve tried editing scripts, renaming objects, nothing made it publish.

This has happened a lot in the past but I was usually able to get it to publish by editing a script and trying again.

1 Like

Did you try publishing with scripts open and being edited? (CurrentEditor ~= nil)

I’ve tried both with and without. Doesn’t have an effect. If you do have scripts being edited though, they don’t even get saved by the autosave every 5 minutes: Autosave Team Create scripts even if they're being edited

Yeah, I tried publishing with scripts open, and no scripts open.

Not sure about anything team create related, but I’ve been trying to update my universe game and it says successful upload like always but the updated label remains at 5/25/2016. Thumbnail remains unchanged. Possibly related?

I’m not currently seeing this issue on any OS. Is this still happening, and does it happen to an empty baseplate?

I am getting this error too, I’m just clicking publish regularly and nothing has changed since the past 3 days

I haven’t experienced it on a baseplate, but it seems to be working now!

Nope still not working for our team, we’re sitting ducks at this point.
Please find a fix quick, thank you

Have you restarted all of the clients/server in the past few days? Is this happening to you on an empty baseplate?

I have been shutting down all servers every time we do an update through multiplayer studio’s publish and it’s still somehow not updating.
The only publish that works is the regular studio publish, I tried disabling multiplayer studio and then downloading a copy and publishing it through there and that worked.

I will try the baseplate multiplayer studio update test right now and report to you immediately.

Hi, I’ve tested the baseplate test with my friend in multiplayer studio. It seems to only happen if my friend publishes from his side and after shutting down when I go to join it, it still gives me the old server.

Maybe instead of publishing, it’s the server somehow slowly catching up. After 5 mins and shutting down the update went through?
I have a video footage of this bug appearing.

Video explanation:
I published a version with trees and I told him to publish a version without trees. The server gave me a game with trees in it after shutting down. Then I go in edit multiplayer studio to see if the trees are there or not, and it gave me my friend’s version without trees which is the correct update.

Is it possible that your friend published the place after you joined the game the second time, but before you clicked Edit? I’m still not able to repro this issue.

That can’t be possible because I published with the trees in the thumbnail and in the video was recorded with the page already refreshed with the removed tree on the page. :open_mouth:

But my friend reported to me that the bug is fixed as of last night.
I’ll contact you via this thread if any new issues appear. Thank you for time and patience =)

No problem. It may have just been a slow server somewhere then.

1 Like