Team Create Users Cannot Update Packages

Users that did not create the package to begin with are unable to publish changes to the package, even if they make changes and are prompted in Studio that changes need to be published first. The context menu simply doesn’t show options to do so.

If this is not a bug, then it’s certainly not documented anywhere. Or if I’m doing something wrong, I have not been able to figure it out.

We are both using up-to-date Studio (as of 9/25/19) and have the same permissions to edit the game through our group. We both tried leaving and rejoining, but that didn’t work either.

Here’s a video of the issue that my friend and I recorded:

I would ask that this video not be shared outside of this forum, thanks!


This is because only the owner of the Package is able to publish changes to the Package. This is currently intended behavior. We are working on a feature that should ship in November that will allow you to add collaborators to your Package.

Apologies that this feels like a bug! We are hard at work at making significant improvements to Packages. We will reach out to you for early feedback on the feature in the coming month.


Alright, thanks for the quick response!

I didn’t want to make a bug report for this until Packages are better supported in Team Create, but a little over a month ago when me and a friend experimented with them, whenever I updated a package I created, his studio would crash, and the same thing if he created a Package and updated it, mine would crash.

Should I make a report for this now or wait until the permissions changes are shipped?

I’m not an engineer there, but my guess is that it would be best to wait a couple months and see what improvements are rolled out.

I found this topic whilst looking for solutions to a problem I’m currently having, similar to this one.
The only problem is, I am the original creator of the package.

Whenever I make changes, it doesn’t allow me to publish changes to the package. I simply tried copy and pasting the package (with changed code) and replacing the outdated scripts with the new one, but when I opened teh cloned scripts, nothing was updated.

It was like a ghost package. I had made changes to it, but the server knew no such thing.

The main problem that came from this is I can’t publish the game, as there are outdated packages hanging around, and I can’t update them because apparently I havn’t made any changes!

Please help >.<

Can you please explain in details of what changes did you make? Did you change a script? A model?
Besides that, is this a teamcreate place? Can you give me the minimum steps to reproduce this issue?

I made some very small changes to a sever script from the workspace.
All the script was designed to do is kill whatever touches it, and it was a package (this is so I could easily make changes without having to change several other scripts.)

I had to take the place out of team create in order to publish it, but at the time, this is what was happening:

I had just made some changes to the script in a teamcreate place, closed the script editor, and proceeded to publish the changes to the package, but the orange circle (that normally appears when un-published changes exist) was nowhere to be seen.

I tried to right-click and publish changes anyway, but I was not given the option.
I then went into the game explorer, and tried to update all of the packages anyway, to see what would happen.
After all of the packages were updated to the most recent version, I went into script editor on one of the other scripts that had stored the original code.

It was still the same, none of my changes were there.
I tried publishing the game, and closing studio - but I couldn’t publish it because there were still packages with unpublished changes.

As far as I can remember, I don’t think it even gave me the option to select in explorer.

1 Like
Please let me know if this solves the problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.