Team tools wont appear when joining your game

See, I have experienced this many times. Team tools wont appear in our backpack when joining the game. Im not sure if you are experiencing the same problem but I hope this gets fixed.

  • Im attempting to find a solution for this problem, neither if its my fault or is it Roblox Studio.
  • So, for example, you add a sword into the police team, and you want it to be for police only, the tools you added will not appear in your backpack when joining. Instead, you will have to add it in StarterPack to make it show up which I dont want. I dont want everyone to get the sword, I want it to be police only.
  • So, since I have adonis admin in my game, I tried to add the tools in ReplicatedStorage so we can do :tools, but it still wont appear no matter what. The other solution I tried is to re add the tools but it didnt work as well.

So I wanna hear from you, are you experiencing the same problem or is it just me? Do you have any solution?

Thank you for reading this thread.

1 Like

I don’t think putting a Tool in a Team has worked without you actually scripting it for ages, if at all.

Yeah, the simplest way would be to :Clone() the tools to all of the players backpacks in that team.

1 Like

Ah alright, I’ll give it a try. Thanks for the reply though.

This is not a native behaviour, you need to script this yourself. There are various free resources in the toolbox that you can reference or you can try and make your own script for this. It’d probably be better to do it yourself now that those scripts are probably outdated.

Since players have a property called Team which is a reference to the team object for which team they currently belong to, you can check if that’s non-nil and then just clone tools from it to the player’s backpack. Probably the simplest solution I can think of off the fly.

My code’s crude and not a good idea at all (I create a new function for every player), but you can probably figure something out. This is just an example.

local Players = game:GetService("Players")

Players.PlayerAdded:Connect(function (player)
    local function characterAdded(character)
        if player.Team then
            for _, potentialTool in ipairs(player.Team:GetChildren()) do
                if potentialTool:IsA("Tool") then
                    -- Assuming Backpack exists when CharacterAdded fires
                    potentialTool:Clone().Parent = player.Backpack


    if player.Character then
1 Like

Well then its my fault. I’ll try to find some solution combining to your scripts and maybe fix my mistake. Thank you for the solution, really helpful.