Teams no longer sort based off of inserted hierarchy

Teams currently do not have a SortOrder to help organize them, but the workaround for 10+ years has been to insert them in a specific order to maintain an ordered team list.

Expected Behavior

The first team put in the Teams folder should appear first on the list of teams. The second team put in the Teams folder should appear second on the list of teams. So on and so forth.

Actual Behavior

Teams are sorted seemingly at random.
image image image

Relevant Info

  • Latest version of Roblox Studio
  • Windows 10
  • Not entirely sure when this bug started, but sometime within the past week
  • Could be related to the ReplicatedFirst change?

This change is likely related to the post you linked. Before enabling the change you linked, we enabled a separate change so that the default team UI scripts would account for the change in arrival order. Do you have a custom team presentation UI script in your game? Please share a link to the game where this is happening.

1 Like

Does this possibly only happen in studio in Play Solo mode? Does the issue also happen if you start a test server and test client?


I do not have a custom or forked team UI script.

This is the place ID: The Day the Noobs Took Over Roblox 3 - Roblox

It happens in both Play Solo and test server/client.

I downloaded a copy of the place, when i run it locally the teams order is consistent. teamorderstudio
I downloaded a copy of the place, when I run it locally the teams order is consistent. We tried changing a flag setting on production, does the issue still repro for you?

1 Like

It’s still ordered randomly in Studio’s Play Solo and test server/client.

Are you running under team create? Do you possibly have any plugins that might be affecting the Teams?

When I downloaded the copy, I didn’t include any LinkedScripts, is it possible that you have a LinkedScript, or require a script by asset id, or load a script via insert service that may work with Teams?

Not using team create, however I have collaborative editing on if that matters.

I don’t use any plugins that affect teams. There are LinkedSource scripts, however none of them affect teams. There are no scripts that mess with the Teams folder/service.

If it helps, this place is extremely simple and experiences the exact same problem:

It looks like a fresh install of Studio resolved the issue? Strange, but I’ll take it. I’m guessing it somehow didn’t change the flag when you mentioned it in your earlier post.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.