Teleport To Game With GUI Issue

I’m trying to make a game teleport GUI that teleports you to a different game using a scrolling frame (for the teleport button placement) and the button is made out of a frame (for the backround) and an image button as the actual button.

Ive tried multiple scripts with a lot of them saying you cant teleport in the studio. I
keep thinking that it will work when i test it on actual Roblox, but when i try to test it, it’s not teleporting!!

If someone could please help me with figuring out how to teleport to a game with a GUI i would really appreciate it!!

1 Like

Makesure you have the right PlaceId and use prints to assure that there are no errors

Hi, could you maybe show the script?

1 Like

Ive used multiple but heres one of them

game:GetService(“TeleportService”):Teleport(Put game id here)

Here’s some assistance to your question;

  1. Make sure you have the right place ID.
  2. Make sure you allow Third Party Teleports (This means; if you don’t own the game, you can teleport to it as well, i.e; just because you own a group, doesn’t mean you’ll be able to teleport to it.)
    Here’s where to enable it
  3. Post the current script you’re using! We can help find any errors as long as we have a script to work off of. Without the coding; we’re missing a crucial part.
  4. Try using the print command to debug your script! It helps a lot.

Just for future reference, if this doesn’t fix anyones issue; read this post as well on this post.

Where do i allow 3rd party teleports?

I am not 100% sure but can’t teleport on client I guess. Second, :Teleport needs a couple of more arguments.

game:GetService("TeleportService"):Teleport(placeID, player)
  1. Capitalize the C in connect, that version of the connect function is not supported by Roblox.
  1. Look at the screenshot I sent you. That’s in the game settings when having your game loaded up.
  1. He is right, if you want to have it where it’s just the PlaceID, it needs to be in a local script. Client teleportation only works for certain situations from my experience.

yeah but I saw some scripts which still works with :connect
I think that isnt the problem

1 Like

Oh it isn’t the issue, I only wanted them to fix that due to Robloxs preference of developers to not use it.

I Got It Fixed Thank U!!
I didn’t know You had to allow 3rd party teleports!!

1 Like

Third Party Teleports is only neccessary if the place you wanna teleport to isnt owned by your game.

1 Like

Glad it worked, please mark the following post as your solution so people don’t think this is still an issue!
Have a good day.