TeleportGui not localized during teleportation

Hello,
I have been trying to localize my game and noticed that during the teleportation to another place in the same universe, the texts on the TeleportGui are not localised.

More specifically for my case, before teleportation, a random text is generated and a tween is played, which is localised correctly until the player is being teleported. During that more or less short amount of time, the text gets back to the original one, and once the teleportation finishes, the text gets localized again.

Video of the issue:

Game where it is happening (use French locale and play any game mode to be teleported): SAKTK Test Servers - Roblox

Creating a repro is kind of painful because it requires two separate place files and they also need to be published for teleport operations to work which makes a repro hard to create. I hope I provided enough information nevertheless.

1 Like

Is it strange that this has been happening to me as well?

I have been trying everything but nothing seems to be working. @homermafia1 I might not be able to help, but since it’s happening to me as well i will try to find a solution!

I believe it’s cached, try setting the language before setting it as the teleport screen.

I tried but it did not work neither.
Here are actually more details on the order in which I did things in my report:

  • When the player joins the game, set the TeleportGui (texts are empty) (located in ReplicatedFirst)
  • When the user wants to teleport, set the text in source language (translation done automatically by looking at the translation table expected)
  • Parent the TeleportGui to PlayerGui and tween it to opaque
  • When the player arrives, put the TeleportGui back to PlayerGui and tween it to transparent

I tried, as you said, to set the TeleportGui after setting the text, but it did not change anything.
Then I tried setting it after I parent it to PlayerGui, but it did not change anything neither.

1 Like

Thanks for filing this issue. We are looking into it!

4 Likes