Teleporting to place not working (Client initiated disconnect)

so im trying to make a button that rejoins you when data failed to load.
i already made a gui pop up, and when they click “ok” they should rejoin the game.

this is my script, it should work but when i press it i get this error

local TeleportService = game:GetService("TeleportService")
local Background = script.Parent:WaitForChild("Background")
local RejoinButton = Background:WaitForChild("RejoinButton")
local player = game.Players.LocalPlayer
local PLACE_ID = game.PlaceId

	game:GetService("TeleportService"):Teleport(PLACE_ID, player)


You should teleport the player to a place that teleports them back after 20 or 10 seconds.

i found that other games, could do it with this method. so i was wondering why it wasn’t working.

I get that you’re getting this error but the client can’t teleport anyway only server.

i also tried using a remote event, that fires to a server. and the server firing the line.
that also didn’t work

check your internet, I think i got this error before because of my internet

my internet is fine, i tried using on my pc (with ethernet) and on my phone (with wifi)

Maybe try TeleportAsync and make sure that third party teleports is enabled

it apparently only works if more then 1 people are in the server.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.