TeleportService error, can't teleport to a place within the base game

Hey, my issue is that I have a part I touch and I want it to teleport the player to a place that’s inside my asset manager.

I tried with many dev forum posts and there isn’t much variety and I can’t find anyone that can re-create my error. Trying to realize what’s happening for a few hours already…

				local plr = plrs[hit.Parent.Name]
				local placeID = 3899763580
				tps:Teleport(placeID, plr)

The lines of the script, simple Teleport.
I have tried to use pcall, and use the same sample from the wiki itself but it keeps prompting me this error.
Whenever I try to teleport to another base place it does work but it does not work when I try to teleport to this “place inside the experience”…
Any help please it’s really frustrating!
edit: Idk what the error means when it says I am not allowed to play this game, I also tried to publish the other place just incase and it doesn’t work.

I’m sure you have read this…

Teleporting Between Places.

Yeah, of course. And I obviously have the third-party teleports thing enabled.
unless you refer to something i’m missing

local placeID = 3899763580
local reservePlaceID = teleportService:ReserveServer(placeID)

local plr = plrs[hit.Parent]
teleportService:TeleportToPrivateServer(placeID,reservePlaceID ,{plr})

Try this if its not working tell me

1 Like

Do you want that the Player joins his own private server or to a Public Server?

I want it to be a private server after all. It works maybe because I used to do something else.
I swear the magic of forums works wonders?..

1 Like

The reference page says to use TeleportAsync… you just use Teleport.

Beforehand I used the entire “SafeTeleport” module, it didn’t matter but it randomly works

Tmm good, u also dont need to use .Name just take the Player

1 Like