Terrain editor breaks when the Regions button is clicked

The terrain editor breaks when the “Regions” button is clicked.

How to reproduce:

  • Open the terrain editor.
  • Click the “Regions” button.

Clicking the “Regions” button generates the same error again and again, along with duplicating the “Edit Tools” collapsible titled section.

50 Likes

Think it’s a bug, it’s happening to me as well.

10 Likes

Same problem here, me and a friend can’t get it to work.

10 Likes

Just tried using regions and this happened to me too.

6 Likes

This is happening to me too. It seems as if it is duplicating!

5 Likes

We are actively investigating this issue. Stay tuned.

19 Likes

This is happening to me as well, and it should be addressed very urgently. Yikes!

6 Likes

Same here, hope it gets fixed soon :slight_smile:

2 Likes

Does anyone have a way around this bug?

3 Likes

Since the terrain tools are loaded in from an .rbxm file you can either make the change yourself or use the file I’ve provided here to replace it with: TerrainTools.rbxm (147.0 KB)

All I’ve done is changed a line from textLabel.Text = text to textLabel.Text = text or "" and it seems to be working fine. There are just a few missing lables but it’s a good enough temporary fix.

Using my file:
Navigate to C:\Users\%username%\AppData\Local\Roblox\Versions\version-ce98c29615704941\BuiltInPlugins
Replace TerrainTools.rbxm with the file provided
Start a new studio session, the problem will be fixed, for now at least.

Do it yourself:
From inside of studio go to insert model and navigate to: C:\Users\%username%\AppData\Local\Roblox\Versions\version-ce98c29615704941\BuiltInPlugins
Insert TerrainTools.rbxm
Open the ModuleScript TerrainEditor/Libs/ImageButtonWithText
Go to line 47 and replace textLabel.Text = text with textLabel.Text = text or ""
Right click on the TerrainEditor folder and save it as a model to the same directory as before in the BuiltInPlugins folder, overwriting the TerrainTools.rbxm file.
Exit the studio session and launch a new one, the problem will be fixed, for now at least.

This won’t cause problems with future updates as the file will made redundant when studio updates in the future. It’ll probably be similar on Mac but you’ll have to navigate to the Roblox Studio folder yourself. Sorry!

13 Likes

I was going to make a topic about it, haha. Since I found this, I bet many people are experiencing this bug and will need to be fixed as soon as possible.

3 Likes

When I did it for the first time, it did work, then now (Like right now), it stopped working, I downloaded this again, and still doesn’t work. Captsdsddsure

I don’t understand why it would just randomly break and continue not to work after repeating the process. Make sure you’re definitely overwriting the file, I’m not entirely sure what the problem could be in your case, sorry.

When I made a fix for it before, I was a little rushed as I knew I should be revising for my exam but saw a great opportunity to procrastinate - just as I am now!

I’ve looked into this problem more, the error isn’t actually due to that line but root of this error is supressed due to the place it occurs being in a pcall function for localization. An error is being thrown because because a few values (Rotate, Move and Fill) haven’t been added to the TerrainTranslations LocalizationTable inside the plugin. This ends up returning a nil value for the translation, which causes the error seen. But after adding these values to the table, the plugin appears to work flawlessly for me with all the lables now showing correctly - I’m not able to reproduce the “Edit Tools” spam, probably because I don’t use the Terrain Editor.

Here’s the latest version for you to replace it with: TerrainTools.rbxm (146.4 KB)
All I’ve done in this version is add the missing values to the LocalizationTable (and I think I might’ve broken the Chinese translations while I was at it, sorry).

2 Likes

@Sorcus Any updates? I haven’t seen any changes and I will have to publish my game for someone this Saturday because it is a commission. My reputation would decrease if I don’t get it out until Saturday because of this bug.

2 Likes

I got the same problem, it started recently when I was building with someone on TeamCreate.

This bug is fixed in Studio Version 0.75.0.691, which was just released. Thanks for reporting!

10 Likes