Terrain Editor Bug?

For some reason my terrain editor doesn’t work properly when my cursor is hovering over terrain? it sinks into the ground and seemingly locked to a plane, but wont let me erode or ‘snap’ to the terrain where i wish to edit. But weirdly enough there are these areas on the terrain where it identifies that my cursor is there, barley anywhere else. I would also like to add in that i’ve tried restarting studio, and i’ve uninstalled/reinstalled studio as well


1 Like

I found the issue, some beta features were interfering with the terrain editor.

1 Like

Literally having this exact problem right now. It’s extremely inconvenient as my game is almost entirely terrain-based.

Did you completely disable beta features? I really don’t want to have to do that every time I want to create new islands. . .


I don’t know how some beta features can ruin the Terrain Editor. It’s just confusing.

Can confirm that disabling certain beta features “fixed” the terrain bug.

1 Like

i completely disabled all of my beta features, and it worked fine for me

What fixed it for me was disabling the Beta Feature “Accelerated Collision Pipeline.” It may be different for others but this resolved this for me.

1 Like