Terrain editor grayed out


I’m having trouble with using the new terrain editor as it’s grayed out in the studio I’m in. It works in other places, but its just this one place where it doesn’t work.



I’ve tried checking if anythings up with the terrain properties, but it seems like there isn’t. I’ve lso tried turning off all my plugins.

Output if needed


It looks like you have a Folder in Workspace named Terrain. Maybe the terrain tools should use FindFirstChildOfClass?


Changed the name of the folder and that fixed it, thanks.


Found the problem. If you were normally to index for Terrain under Workspace, you would be guaranteed to get the Terrain class because Workspace has a Terrain property, similar to how game (DataModel) has a Workspace property.

Stickmasterluke indexes the Terrain class in some of his code via WaitForChild on Workspace:

Either we need a WaitForChildOfClass() (these function names are getting long af) or the code should be modified to repeat wait() until workspace.Terrain.

PS: Lowercase RBXScriptConnection:wait() is deprecated im triggered.


Wow, they actually don’t do a class search and instead search by name. That’s weird.