Terrain editor window doesnt show anything

So i wanted to use terrain editor but when i click the terrain editor button on home page or view page, it doesnt open anything, i tried opening it by right clicking the ribbon and then clicking the terrain editor, this opened terrain editor window but its just empty gray space.

(edit) i tried reinstalling studio, resetting studio settings, updating my graphics driver

Any help to fix this issue is appreciated


having the same issue… really hope this gets fixed soon i just did a massive terrain merger and would like to work on my game.

happened to me as well, i guess its due to the recent update

Same issue I have. Aftern the update

Look for a terrain editing plugin, i doubt there is any, but worth a try.

I was having this issue too but I fixed it by disabling “Terrain Editor” in beta features. Hopefully they can fix it soon.

1 Like

Please check again to see if you still have the issue. If its still there, you can disable the Terrain Editor Beta in the “Beta Features” menu as specified by @RichardEinherjar

We tried enabling a flag that should have fixed error reporting when Terrain Editor is first initialized and it didn’t cause this error in my own usage. The flag has been disabled and I will go back and take another look at it.

Sorry for the inconvenience and thank you for your patience as we try to put some of the finishing touches into the beta!

1 Like

oh there you are staff member.