Terrain Editor's "Fixed Plane" setting not working

We have new terrain tools, one of them is “Flatten”. I was playing with the tools today and found the terrain not growing beyond a certain height.

https://streamable.com/b1z1r

What I found was the “Fixed Plane” setting.
17%20PM

I clicked it on and found it set to 30.
42%20PM

Which is where my terrain was stopping. I tried setting it to a higher number and sure enough the terrain grew higher. However clicking “Fixed Plane” off doesn’t work. The flatten tool still moves the 3D grid up and down after you’ve clicked, when it should actually lock that grid in place and ignore the Fixed Plane height number since it’s off.

This tool worked correctly in Beta, where as soon as you clicked, the grid would be locked at that Y and you could grow terrain up to wherever you clicked. Now there’s no control on the grid.

I’ve tried resetting studio and everything. I’m running the latest version of macOS. This bug began happening ever since the Fixed Plane and PlanePosition were introduced.

8 Likes

This will be fixed in the next release. Thanks for the report :+1:

1 Like

Just released the fix for this!

1 Like