Terrain glitches

Hello there, i’m Yor_ick. I currently had some problems with terrain. Not blocky terrain, i mean the terrain from roblox, with the grow, smooth etc… anyways, i made the game out of alot of terrain and it looks perfect on roblox studio. When i go on my mobile device and join it the terrain has completely moved and i dont know how to fix it… yes, i have rejoined multiple times but it didnt change. Can you help me out?

I hope you have a solution.

2 Likes

Please take screens shots of what the terrain looks like in Studio as well as what you see on mobile (all mobile devices have a screenshot feature, just post them on here as-is. Use the snipping tool for your PC).

Without visuals, we can’t do much to help.

4 Likes

As @Aotrou said, provide screenshots so we can see what your getting at, by the sounds of things it seems like the terrain has moved to adapt to the graphics on mobile, so it is more supportable.

1 Like

Terrain Level of Detail doesn’t move the voxels, it rounds them based on the voxels around it and the distance of the player’s camera. When the player moves closer, their LoD would return to normal (not moving) regardless of the device it’s being shown on :sunglasses:

There’s really nothing to speculate here to be honest haha - the OP just needs to provide images so we can know for sure :stuck_out_tongue:

4 Likes

Are there any scripts in the game? It could be a possible solution that something with the scripting is messing with the terrain. I don’t have much to work off of so I hope this helps. Once you update your post some more, I could give more feedback/possible solutions.

Edit #1: If there are scripts, save the world as an rbxl file, open a new game/world, the load in the rbxl file and delete the scripts. After you delete the scripts, test the new game on mobile. Or you can just delete the scripts in the original world and then test it, then later add the scripts back. Either way, it’s your choice.

1 Like

There are only teleport scripts. Thats all i need for now, since it doesnt has special features, but i will try that.

I can only send the mobile screenshots right now, because i have only 2 minutes.

, here’s also a link to the game if you want to see the glitch by yourself. https://www.roblox.com/games/4298398538/YorickRBLX-s-RTC-Gamerinoss-Hangout?refPageId=718cb59f-4d1e-440d-be82-a6e6f906f276

And this works when you are play-testing in studio, or does it just work when you are editing in studio?

Here are the pictures ingame and in roblox studio(edit)

Here is a screenshot where i am ingame on mobile and in edit on roblox studio. You see that there is no glitch in roblox studio but there is a glitch ingame.

This is really odd - but I don’t think it’s a glitch. I think you might have some weird code going on that’s moving the objects, not the terrain, but it’s hard to tell for sure.

If you’d like, you can DM me the place file and I can check it out on my end.

1 Like

This may be a glitch on your end. I tested it on mobile and the terrain is just fine. I don’t know If you tried deleting the scripts already but the terrain works.

Someone helped me to fix it, thats why the glitch is gone. A huge thanks to @Aotrou for fixing it though

What was the problem? Is it possible other people might run into the same problem?

1 Like

You gotta ask @Aotrou , he knows to explain it the best.

It was a faulty free model script. I removed it from their group’s game and everything worked fine after :stuck_out_tongue: