Terrain stretched out at far distances

I’m creating a highway on top of smooth terrain and I’ve painted cement under the road so grass doesn’t stick through it. I’ve tried not painting as big an area under the road but the same thing happens. Is there a way to stop stretching from happening when you go further away? If not what else could I do to stop grass from sticking through without raising the highway up?

How about placing the road more above the ground?

I am pretty sure its just how ROBLOX works. I suppose there is no way to fix this, unless some person more knowing then me comes.

it’s either this

or this

I’d guess that it’s theeditor quality level try setting is to level21 (may cause crash or insane lag)

1 Like

Might just have to do this unfortunately

All those rendering settings are maxed out for me already