Terrain tool wont work on part-terrain

I’m trying to simply paint and grow some terrain. However, all the terrain tools bug out and don’t show up when hovering above terrain. I used part-terrain plugin to place the terrain (which works the same as the in-built terrain tool one.) Any ideas of what could be causing the problem?

Solutions I tried:

Brush tool went through the terrain onto the baseplate so I deleted the baseplate but that didnt help.
Disabled smoothcam plugin but that didnt do anything.
Tried reinstalling studio.

Have you tried resizing or minimizing the terrain tools, basically playing around with the settings? If your brush for example is too small or too big, it might not be working normally.

Ive tried using Bottom/Center/Top along with all the possible sizes

That’s weird, make sure to move this topic to #bug-reports:studio-bugs so people can get a better understanding of the situation and eventually help you out.

1 Like

from my experience, the only way of fixing it to restart studio. but this is not 100% reliable solution. :neutral_face:

Try copying the terrain to another game and try if the tools work there.

I started having this issue as well but didn’t see how it was fixed. How were you able to fix it?

just happened by itself, didnt really do anything

note: change around the axis of the grow tall occasionally and it fixes it for a few mins