Text delayed when typed into script (macOS Sierra)

Yes, exactly what was mentioned in that thread. Can I get a timeline for when it may be fixed. Cause this sadly prohibits me from doing any programming on Roblox. :confused:

1 Like

There’s a comment from twberg that should help. If not, we’re still looking into other possible upgrades to performance, but we don’t have any timeline for it yet.

I understand, hope it can be resolved sometime soon. Thanks for the responses.

Edit: Follow up question, how would I get notified when the issue has been resolved?

Hope this is fixed soon! It’s been a nuisance since June of this year for me and it’s really annoying.

Don’t hold your breath on it being soon :confused:

1 Like

This issue has gotten dramatically worse. I can no longer write code in Roblox Studio. I can write in a different program and use copy and paste but it delays my progress without being able to use the autofill feature and also having to constantly switch between programs to examine the data hierarchy. Is Roblox still working on this? It is a MAJOR issue.

1 Like

I’ve been having this issue as well. I started experiencing this issue around a month or so ago. The simple solution, as you mentioned, was use an external doc, but that delays and is not super smooth. I have a windows computer I use for coding but it is annoying to switch between computers.

(I was told to make a new thread regarding my studio bugs, but I do not have permission to open a new draft on the Studio Bugs category)


This is what to do in order to report a bug. We are new members and we cannot post in the bug reports section yet. So I was told to follow these steps:

  1. Make a thread in the #bulletin-board about your bug report.
  2. Make sure to follow the Steps to Report a Bug in your thread: Please Read Before Posting: Steps to Report a Bug
  3. When you are done with your thread in bulletin board, click here to send a private message to the Post_Approval group.
  4. Include the link in the private message, and send it.
  5. We will work with you to make sure the reply is of high enough quality and then we’ll move it to the bug report category for you if we approve.
1 Like

Thank you, will do.

1 Like

Two months ago I was getting this issue, I had to get a new Mac to fix it due to a surprising lack of roblox support in trying to fix it.

Now i’m experiencing the same issue again.

I would really appreciate it if roblox could take a serious look into this since its not really plausible to expect developers to get a new device every 2 months just to be able to program.

1 Like

New info: This issue is Reduced by moving everything out of the main window, however this wastes a ton of screen space and makes development significantly slower. Still desperate for a fix since my development has been impossible for 9 days now.

1 Like

Further explored the issue today by resetting all my studio settings without a fix:

List of things ive tried so far:

Using another Mac,
restarting my Mac,
reinstalling studio,
restarting studio,
Chaning my color profile,
disabling plugins.

1 Like

This issue has been progressively plaguing me for months now, and my programming has suffered as a result.

I use a mid-2012 Macbook Pro 15 inch with an i7-3720QM, with a GT 650M. I can’t remember when this issue appeared, especially since I didn’t do much programming earlier this year and later last year. I would say it wasn’t around prior to the fall though.

No updates or fixes Roblox has released has solved it, and it’s INCREDIBLY bad.
This is how bad it is.
For comparison, the full message was “–hello everybody on the devforum”
I finished typing at 0:03, and it wasn’t done until 9 seconds afterwards (not shown). Can we please get a fix for this, it’s debilitating as writing comments for my code is almost a painful process, let alone any mistypes I have to go back to.

I’ve tried restarting and reinstalling studio, I downloaded Studio on a 2017 Macbook Pro (not mine) and it had the same issue, I’ve restarted my computer and shutdown my computer numerous times, It’s been repaired, I’ve disabled plugins and disabled the autofill box through Studio Settings. None of it has made a dent, and it’s been getting worse as time goes on.


mine is even worse - taking about 2 seconds per letter :grimacing:

Ive also noticed this too, for about a week before complete meltdown it appeared like my script editor was running in a delayed way.

I think its outrageous that roblox hasn’t had the curtsy to even respond on the issue, given a large amount of Mac developers are suffering on the result. I would even appreciate being told a temporary feasible solution.

It is unrealistic for roblox to keep expecting us to buy a new Mac every few months because of an issue on their end.

1 Like

This is why I don’t update to the latest versions of macOS. So far this has worked out for me.

Of course I would enjoy being able to update my OS, but it’s a sacrifice which must be made. :confused:

I hope you’re able to find a stable solution.


I don’t really believe its fair for roblox to give developers the choice between having the latest OS and being safe against se purity threats or the ability to actually use their script editor :frowning:.

Just from the nature of the issue I would honestly imagine it would be an insanely easy and quick fix, since the bug is only found when the editor is in the main window. It would honestly take so little effort on roblox’s part and save so many max developers.


It’s gotten so bad that I don’t want to even work on Roblox anymore. I’ve just started working on my own 2D engine in C++ (Roblox should add better 2D asset support and abilities), and it’s sucked up the time I’d normally spend programming in Roblox just because the issue has devolved into the fact I can hold up a conversation with another person while Studio types at a crawling pace:

It’s gotten FAR FAR WORSE!

At about 4.5 seconds in I finished typing --allow users to set their own appearance., but all you can see in SEVEN SECONDS is --allow . I am honestly INCREDIBLY disappointed in Roblox, and I hope they can get a fix in ASAP because this is far more important than volumetric clouds, no matter how beautiful they will be.

1 Like

After going through the route of customer support, roblox refused to co-operate with resolving the issue, despite huge patience and support from my half, truly disappointing and a sign roblox does not care if this issue is resolved or not.

Thankfully I found a temporary solution if making a new account on my Mac and installing studio, this seemed to fix the majority of the problems I had been having.g

Please save and send tnavarts your config files identified here, and see if deleting them fixes the issue.
CC @marfit

I can not find aforementioned Roblox folder when I search ~/Libary/Preferences

1 Like