Text not showing up in plugins or UIs?

Seems like it’s random but for some plugins literally no text is visible. For some of the UIs I’ve made, the title doesn’t show up, but if I check it in explorer, it’s there. No properties are changed that would make it invisible, and clicking on it still outlines it in blue.

Not sure if this is a bug or a coincidence or something stupid I did but it’s really annoying. If someone else is having this problem it would be nice if you’d share you’re having the same problem so I don’t feel crazy/how you fixed it. Tried adjusting z-indexes on UI elements and it has no effect.

In Moon Animation Suite, it looks like this:

In Stravant’s gapfill plugin:
image
In my own UIs, the title label doesn’t shop up. It should say “Shield Shop” in this one. There’s many of them like this and it shows up in none of them. image

Has text and the label is a decent size, but it says the TextBounds is 0, 22.

Also seems like some other people could be having a problem as well, atleast with the Moon Animation Suite. Looked at comments and someone said no text showed up.

I’d rather have posted this in Bug Reports/Platform Feedback but it doesn’t let me post there so this was the next best thing. Any help would be appreciated.

Can you please post the properties of both the TextLabel and the Text? Any one of them that is not visible is good.

Also, please provide the properties for any GUI’s “behind” the text label.

Edit: It doesn’t seem like a “Scripting Support” category issue from what I’m seeing here unless Moon Suite has code that is changing properties on its own. In either case, if it isn’t an issue with your code that you want assistance with; I don’t think this topic belongs in this category.

You need to go through the post approval process in order to post there. If you haven’t already, send them a request.

More info (see rule 15.1):

cc @lil_revvy

New Members are able to create Platform Feedback threads only if a subcategory is chosen. The new topic button will be active and threads can be submitted to those categories. For New Members, posts are taken out of the category and redirected to the post approval inbox.

What OP most likely tried to do was post to the Platform Feedback category. No one is able to post in the top-level category. To be able to post to a Feature Request or Bug Report, we require that users select an appropriate subcategory for their request and place the topic there.

2 Likes