Textbutton not being able to be activated when parented to the player in VR

  1. What do you want to achieve? Keep it simple and clear!
    I want to be able to press the TextButton with my other hand in VR.

  2. What is the issue? Include screenshots / videos if possible!
    When I try to press the TextButton with my other hand it doesn’t work at all, It doesn’t even hover over the button. It simply ignores it.

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I’ve Tried looking through the properties of the TextButton but none seem to have done anything, I’ve also tried looking online but I didn’t see anyone else have the same issue as me.
    Using SurfaceGui.Adornee also didn’t work.
    For all I know it could be impossible. In that case I’ll have to use a work around but I’d rather not.

If I try to use this code on the fake hand then it works perfectly fine, but if I try to use it on the real one, it doesn’t activate.
It also doesn’t work on the fake hand if I parent it to the player.

	local lefthandrightgui = game.Workspace["fake lefthand"].LeftHandRightGui:Clone() -- gets the Gui
	lefthandrightgui.Parent = leftarm -- Parents the GUI to the left hand
	lefthandrightgui.Nodelay.Activated:Connect(function() -- When the TextButton "Nodelay" is actiavted this should happen
		lefthandrightgui.Nodelay.BackgroundColor3 = Color3.fromRGB(255,0,0) 

Sorry if this has already been asked before or if I’m just blind and missed a property.

I don’t know a solution, but I might have a workaround. What if you have a folder “Arms” and weld that arm to whatever part is representing the position of the hand? Then it isn’t parented to it, but still follows your arm movements.

1 Like

Yeah that works perfectly fine, for now I’ll do that but it would be better to have it actually on the arm.
Thank you for helping!

No worries! I’d probably play around a bit, see if its possible to make it work in some other way. Is your surfaceGui located in PlayerGui with the adornee set?

If not, maybe that somehow fixes it (for some reason??), might be worth a try?

Sadly doesn’t work, great try though!