TextButton not working inside plugin widget

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I am working on a custom explorer, and ingame while testing it works perfectly.

  2. What is the issue? Include screenshots / videos if possible!
    When i publis it as a plugin, it gets the contents, so the script works, but the buttons dont.

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I have tried changing their Z index, changing every other element’s Z index, but nothing worked.
    I didnt find any resource related to this.

This post may have some information that can assist you.

If not, try to locate the source of the problem by using print() and warn() at different points in your script
i.e. When you press one of the buttons, before running anything else put a print() to alert you that it did run the function, and put another print at the end.

Also try ensuring that the gui is correctly parented to the Widget (Dont use screen gui)

Im not sure if this post helped AT ALL, however, without having access to the code it is harder to debug. To assist people later on please attach the code.

1 Like