TextButtons on SurfaceGUI doesn't detect clickings

Hello developers! :wave:
I’ve been working at some virtual keyboard GUI, but button doesn’t seems like not working.


However, buttons do detect when I turn SurfaceGui.AlwaysOnTop.
And, buttons of other GUIs do work without turning SurfaceGui.AlwaysOnTop to true.

I think I’m making that GUI same as other GUIs do, but what is wrong? so I wanted you to ask.

Thanks in advance! :grin:

Edit 1: SurfaceGui is contained at PlayerGui (Local), attaching to part by adorning.
Each GUI has their attaching part. For example,if there’s 2 GUIs, there is 2 part attaching.

Here is what GUI looks like in 3D position.
I guess there is no objects avoiding to click buttons but somehow :man_shrugging:.

1 Like

I recently read a post that solved the exact same issue by setting the face to Back. I’ve encountered this as well, some SurfaceGui’s being interactive only at an angle.

1 Like

That’s exactly right, Thank you so much.


as @g_captain said for surface gui, you can make face to back side

and if you are looking for billboard one

make somthing like this

and then go in properties of billboard gui then set this to part:

Then button on billboard gui will work!

NOTE: The billboard one will works with surface gui too!


1 Like