TextureId keeps reverting to the previous value

  1. What do you want to achieve?
    I want to clear the TextureId such that a model part has no texture

  2. What is the issue?
    If I clear the TextureId value then once I run the game in Roblox Studio the property is auto set back to the previously set texture ID. How do I keep this value cleared out?

  3. What solutions have you tried so far?
    I tried setting the value to empty, “”, nil.


You gotta delete the texture completely.

What if it’s a texture still used by other parts and other models? Seems extreme to have to delete it, re-create it then reset it on all models that use to use it. Is there really no other way?

1 Like

You can upload a texture that’s completely transparent?

No because i need to set the color of the model part and if it has a texture then i cant set the color.

For my exact scenario, I have a character customization dialog. In this dialog I have made it so players can pick any color they want for their hair.

To set the hair color the character.Hair.Handle.Mesh.TextureId must be nil so that i can then set:

character.Hair.Handle.Color = selectedColor

Yeah, for this scenario you would have to do what I said, delete texture.

I tried this but it fails. This is my steps:

  1. Set TextureId to an existing texture
  2. Delete the texture
  3. Save and restart Roblox Studio
  4. Run game.

Result: The TextureId is set to the first texture in my list of images. It seems like its always trying to forcibly set it.

Have you tried this:

  1. In Asset Manager, right-click on the texture and select ‘Remove from game’
  2. Remove all textures (not just the ID, but the instance itself) that reference that texture
  3. Publish and restart Studio
  4. Rename the texture on your PC and reupload it
  5. Copy the texture ID and paste it into a new texture instance wherever you want to use it

Another issue is that the texture you’re trying to upload did not pass moderation standards. I tried uploading a texture just a week ago with a bunch of blots and it somehow didn’t pass moderation standards.

1 Like

I have encountered this problem too, however I copied and pasted a group of textures as I wanted to change the Texture value. The texture value then later reverted to the old values.

I am in Studio Team Create.