The Clouds Instance Disables LocalScript instead of Itself

Reproduction Steps

  1. Launch the Roblox Studio software.
  2. Select any existing project/create a new Baseplate.
  3. In the Explorer tab, at Terrain, create an instance called “Clouds” (you can get it by searching in the Object section). Furthermore, make sure to create a LocalScript at StarterGui.
  4. When you create the LocalScript, make sure it has a tab to edit the script.
  5. While you have clicked in the Clouds instance, on the Properties tab, disable the instance.

Expected Behavior

The Clouds instance should disable itself when you toggle the “Enabled” property in its Properties tab.

Actual Behavior

The Clouds instance disables the LocalScript in the StarterGui instead of disabling itself.

Issue Area: Studio
Issue Type: Other
Impact: Medium
Frequency: Often
Date First Experienced: 2023-09-2023 22:50:00 (-03:00)
Date Last Experienced: After publishing this topic.

Thanks for the report! We’ll follow up when there’s any update on the issue.

Can you still repro this? I cannot reproduce it.

1 Like

Hey, @tnavarts! How are you? I hope you are having a good day! :happy1:

As I hopped into the game where it got affected, the bug seems to be gone now. So… Everything should be fine now!

If I encounter the same hiccup, I will let you know! :happy2: