The frame-rate manager still samples data when the game window is unfocused

When the game window isn’t being focused on by the user, Roblox reduces its maximum frame-rate to 15 FPS so that it doesn’t consume as much of the GPU.

The problem with this is that Roblox’s automatic quality mode actually thinks the game is performing poorly while its in this mode, so it starts to rapidly degrade the graphics quality, and it can take awhile for it to recover due to the skewed sample data.

cc @zeuxcg


Wait, people actually use automatic graphics mode? Every time I have used it in PF for example it turns it up to lvl 9 with AA and then my game lags :expressionless:

1 Like

In that case, it is simultaneously aggressive in the case that I showed, and not aggressive enough in your example.

This is kind of an issue… especially considering that automatic is used by default.

1 Like

We only maintain level 9 if FPS is 50+ in this mode.

I guess because of the way PF is, you get over 50 FPS and then AA kicks in but then it lags and then kicks down to lvl 8< and repeats or something. I don’t know but it’s definitely happened on PF before.

Interesting. We do some hysteresis to try to make sure it doesn’t happen but yeah in case of dramatic performance changes sometimes it may not be enough. We enable AA gradually but even still, sometimes the impact is large. What is your GPU and what resolution do you play with?

Your case is Studio-only I believe - I don’t think we do any throttling on inactive player window. We’ll take a look though, thanks!

I play in 1920x1080 and have a crappy Intel integrated graphics card (HD 530)