The player's head, arms, etc is the dummy's but not the actual player's avatar (STILL NEED HELP)

I am currently working on a load character plugin, and i used a dummy model for the inserting. But when you use the plugin the player’s (that you spawn in) arms,legs,head, etc is not the player’s avatar arms,legs,head,etc.

The following is the script:

        local Players = game:GetService("Players")
        local name = script.Parent.Parent.NameBox.Text

        local cache = {}

        local function getUserIdFromUsername(name)
            if cache[name] then return cache[name] end
            local player = Players:FindFirstChild(name)
            if player then
                cache[name] = player.UserId
                return player.UserId
            local id
            pcall(function ()
                id = Players:GetUserIdFromNameAsync(name)
            cache[name] = id
            return id
        local realname = getUserIdFromUsername(name)
        local dummy = script.Parent.Parent.R15:Clone()
        local newHumanoidDescription = game.Players:GetHumanoidDescriptionFromUserId(realname)
        dummy.Parent = workspace

        local function getUsernameFromUserId(userId)
            if cache[userId] then return cache[userId] end
            local player = Players:GetPlayerByUserId(userId)
            if player then
                cache[userId] = player.Name
                return player.Name
            local name
            pcall(function ()
                name = Players:GetNameFromUserIdAsync(userId)
            cache[userId] = name
            return name

    local idfromplayer = getUsernameFromUserId(realname)
    dummy.Name = idfromplayer

If you know how to fix this, please say so in the replies!

humanoid description can only apply R6 body parts

but how can you apply in R15? I have tried doing it in R15, seems like it adds the shirt,pants,hats,etc but not the body parts.

I made a similar plugin in and it worked fine with r15

Did you use a dummy for it or something else?

Yes I had a dummy and applied the humanoid description to it.

How? Did the body parts also change?

Yes the parts changed.

I will show you soon.

1 Like

Here is a video about it(the plugin sucks because they spawn inside of each other btw):

I am still looking for the save file which I have the script in

1 Like

I found the file and this is what I did:

// I have these functions:

function GetUserId(Name)
	local UserId
	local success, response = pcall(function()
		UserId = game.Players:GetUserIdFromNameAsync(Name)
	if success then
		return UserId

function GetAvatarImage(UserId)
	local ThumbnailType = Enum.ThumbnailType.HeadShot
	local ThumbnailSize = Enum.ThumbnailSize.Size420x420

	local Content

	local Success, Response = pcall(function()
		Content = game.Players:GetUserThumbnailAsync(UserId, ThumbnailType, ThumbnailSize)
	if Success then
		return Content

function GetHumanoidDescription(UserId)
	local HumanoidDescription
	local success, response = pcall(function()
		HumanoidDescription = game.Players:GetHumanoidDescriptionFromUserId(UserId)
	if success then
		return HumanoidDescription

function ApplyHumanoidDescription(HumanoidDescription, UserId)
	local Avatar = Dummy:Clone()
	Avatar.Parent = workspace
	Avatar.Name = game.Players:GetNameFromUserIdAsync(UserId)

When the player presses the button in the plugin:

    local PlayerName = NameBox.Text -- the text box
	if PlayerName ~= "" then
		local UserId = GetUserId(PlayerName)
		local HumanoidDescription = GetHumanoidDescription(UserId)
		ApplyHumanoidDescription(HumanoidDescription, UserId)

Something important to note is that if the player doesn’t exist it will error, but you can just add some if statements to prevent that

1 Like

does it have to be in a local script?

Its a local script that is inside a screen gui

1 Like

The same error is happening again.

Is your dummy R6?

The dummy I used is R15

The R15 version works, I just dont know how to do it in R6. Do you have a solution for this?

this topic is still unsolved! It is currently working in only r15, not in r6.

this is still not solved, (answered, but not solved.) If anybody could still help, thats would be great.