This audio's time positioning is broken

Ok so recently i have uploaded an audio to roblox for a place i am developing and when i tried to change the TimePosition property of the audio it simply does not work as expected.
i have tried with any other audio and it works fine but when i try with this specific one the TimePosition on the Audio is set back to the value i have choosen divided by 2 while the TimePosition property stays at the value i define.

i set workspace.Sound.TimePosition=30
what happens:
workspace.Sound.TimePosition is now 30,
The part of the audio you hear is the one that would play on the current TimePosition divided by 2 (i found this out cause i tried to change the time position to 30 and the only way it worked was changing it to 30*2).

Yet even changing the time position to the one you desire multiplied by 2 this audio will still count as if 30 would be 60 and it doesn’t ignore time length which means as the TimeLength of this sound is 82.115 if i want to play the part on TimePosition 30 the Property would be at 60 meaning i wouldn’t be able to play the rest of the sound cause there would only be 20 seconds left (even though there’s 50) :confused:

this is really bad for me cause this sound is a voice dub for the game separated in different parts on the audio… which means i need to change TimePosition constantly.

i have tested this on both ingame and on studio and yes the bug still happens.
This is an important thing to be solved since other people may upload audios and this bug may happen with they ,meaning they could try to upload another audio therefore ending up wasting robux (i myself have spent 35 robux on this).

i currently don’t have a recording software on my computer to record my screen and studio’s recorder cant record the explorer tab so here’s the audio asset id
and here’s a file of the place with the audio in it
sadbug2.rbxl (18,4,KB)

if you take the audio instead of the place then
1.Create a “Sound” on workspace or anywhere you want
2.Change the TimePosition of the sound
3.Play (you’ll notice the timeposition is incorrect)

i wish this bug to be solved soon as i want to continue the development of my place.

Edit:Accidently uploaded wrong place so i changed the attached place

Wouldnt this topic supposed to be in #platform-feedback:studio-bugs/#platform-feedback:engine-bugs?

I’m assuming he can’t post there yet, so this is the incorrect topic for it.

Did these and can’t replicate whatever’s happening to you.

Did you use the sound id i added on the post?

wait you’re right! i could swear this was the Engine bugs one… i don’t know how i changed it to programming

Try checking this out.

I have checked it already, using the method from that page works for other audios but not for this one.