Thumbnail API for Developer Product does not return the actual image

Thumbnail API bug

Using this API to get the developer product icon does not return the original image, but instead of a blank JSON.

Link: https://thumbnails.roblox.com/docs#!/DeveloperProducts/get_v1_developer_products_icons
Request link: https://thumbnails.roblox.com/v1/developer-products/icons?developerProductIds=54120615&size=150x150&format=Png&isCircular=true
Result:

{"data":[]}

Also, this also affected the developer product creation page:
image
as you can see, the picture frame is broken.

I discovered this bug when I was helping a member in a community, which they have this issue, so I went to the API communication hub and others also have this issue as well. This bug happens all the time, so, I am pretty sure services that use this endpoint will be affected.

Steps to reproduce this bug:
Simply replace [ID-HERE] with your developer product Id and put it in your browser
https://thumbnails.roblox.com/v1/developer-products/icons?developerProductIds=][ID-HERE]&size=150x150&format=Png&isCircular=true

4 Likes

Thanks for the report! We’ve filed this internally and we’ll follow up here when we have an update for you.

2 Likes

I am in the process of checking over bug reports and following up on some bugs that haven’t received any activity in a while.
Is this issue still occurring or can you confirm that this bug has been resolved? We are having a hard time reproducing this issue

1 Like

I am not very sure about whether it is still a problem or not, but I’ve tried checking the link that I’ve attached, and it returned nothing but an empty object

1 Like

This issue is still not fixed.

image