Thumbnail Uploading Bug


#1

Hey!

I was recently “rebranding” my game Player Opener (now Player Unboxing Simulator) in an attempt to see if it attracted people more, and I found a pretty frustrating bug!

I couldn’t upload any Thumbnails nor get a Generated one, as it threw me errors every time, and I know exactly why. (Errors are shown deeper in the Topic)

If you rename your game & it’s supposed to get censored (Hashtagged), but doesn’t, until you hit the Save button for a second time, it’ll bug it out.

I’m bad at explaining things so here’s a step by step on what I did:

  1. I updated the Game Name & Description, didn’t click save yet
  2. I went ahead and added a new Icon to the Game, still didn’t click save
  3. I deleted all previous thumbnails & attempted to upload the new thumbnail, at this point it errored the first time, then I finally hit save

After this, I decided to re-open the “Place Configuration” page and try to add a Thumbnail again, this time it erroring every time.

I tried to upload with different names, different file sizes and everything for quite a long time, and just gave up.

Then after a few hours, I came back to trying to upload the thumbnail, Errors still displayed (Errors seen below this text)

Screenshot_1743
Screenshot_1744

What fixed it though, was that I hit the “Save” button once more, this time with the Place Name & Description tab open, and then came back to Place Configuration & it hashtagged my Game’s name, even though I hadn’t edited it, and it was approved before.

I then tried to add a Thumbnail while the hashtagged version (###### ####### Simulator) was still the name, this time the Thumbnail uploaded and everything went great.

TL;DR: If your game’s name has a name that would normally be Hashtagged by Roblox’s system, you can’t upload a Thumbnail unless it’s successfully censored OR the name isn’t something Roblox’s System would hashtag.