Tool animation not working/playing

I posted a topic not too long ago where I asked how to animate a tool while equipping it (This forum) and many people answered and help, one of which rigged my tool to properly animate, which I still use.

The problem now is that it just does not play for some reason? I have no idea why this happens and I’ve been trying to fix this for multiple days

Can anyone help?

What do you want to achieve? Can you explain it more simple and clear?

What have you tried to solve the issue?

What error are you getting? Can you send the script you used?

If you answer these questions then i can help you more carefully.

What do you want to achieve?
I want to animate a model what is a tool
What have you tried to solve this issue?
Ive asked this in a another devform, many people helped me but non was able to solve the issue
What error are you getting?
This isnt a script thing (I don’t think) but a weld/model issue, the model is supposed to be animated so that its not connect to the hand, but still following it. Instead its welded to the hand and doesn’t separate

I understand.Can you include with screenshoot/Videos?

This is what its supposed to look like:

This is what it looks like:

1 Like

So do you know a solution to this?

Sorry for replying late.I was doing my job.

Also i have no idea about this :frowning:

Its fine, thanks for trying to help though :+1: