Tool doesn't attach to character's hand

So I try to equip a tool to the character’s hand but it won’t It stays on the ground and my arm gets up and grabs something invisible but the tool just stays on the ground

However when I put the tool in StarterPack it is working completely and stays in the character’s hand!

I’ve tried to look for this problem on the devforum but got no success, I also tried just parenting the tool immediately to the player’s character but doesn’t work either.

To note I implemented a custom hotbar and inventory.


1 Like

Are there any other parts in the tool besides the handle?

1 Like

No there are not just what you see

Does it work if you try it without the custom hotbar?

Yes it does work with the normal backpack and custom hotbar disabled that’s what I said in the thread

I understand if you don’t want to, but could you send me a place file with the tool (just the tool not the hotbar and backpack stuff) to I can try to find a solution?

is the Character/Player RigType correct?

  1. I can’t send the sword in another baseplate cause the design is closed-source
  2. There’s no point in not sending the hotbar and inventory since we already know it works with the Roblox’s normal backpack

What do you mean by RigType? The game settings are in R15

I would suggest you try and use Quenty’s qPerfectionWeld, should do the job. (instructions are in the script)

I actually already tried that but didn’t follow the instructions, let me see.

I should just put it in the tool right?

Doesn’t work, it still stays on the ground

1 Like

It isn’t anchored right?

This text will be blurred

I tried it with both turned on and off but still didn’t work it just falls on the ground and stays there

Maybe try removing the meshes and seeing if it works.

That’s what I just did as you see in the picture, I’m just 1 step ahead of you XD

It isn’t locked right?

This text will be blurred

Nah the ‘locked’ property on the handle is turned off