Tool grip not paired with animation


So there’s a clear difference.
I’m trying for the tool to have the same “grip” as the one in animation editor.
In the tool grip(property), they are both 0,0,0, either in the starterpack tool or on the rig.
How should I fix this?

local holding = script.Parent.Holding
local animation ="Animation")
animation.AnimationId = ""
repeat wait() until game:GetService("Players").LocalPlayer.Character and game:GetService("Players").LocalPlayer.Character:FindFirstChild("Humanoid")
local animationload	= game:GetService("Players").LocalPlayer.Character.Humanoid.Animator:LoadAnimation(animation)


1 Like

Something that might be causing the problem is if the animation priority isn’t the right one and the normal Roblox idle animation overrides the animation on the hand’s rotation, or you didn’t have any keyframes for the hand’s animation the animation editor. With the pictures provided I can’t see the tools grip from the front in the ingame picture.

The priority is action.

Were you asking for another picture of the rig? Got a little confused.

1 Like

I tried to recreate the problem, but the test animation and tool grip seemed to work for me.
I have got some questions:

Are you using two different tools to animate and one to test in-game?

Have you also tried to changed the grip to make the one in-game the right rotation to see if it can work in-game only instead of making it the right rotation in the animation editor?(This is probably inefficient)

Is that the only animation playing on the character besides the default Roblox animation script’s animations?

Are both the position and orientation 0,0,0 in the grip?

Slightly Different tools.

  1. No I didn’t try.
  2. Yes, it’s the only animations.
  3. Yes, they are 0,0,0

Would you like the studio file to see for yourself?

1 Like

I think taking a look at the studio file would help.

Sorry for such a late reply!
gripissuedev.rbxl (144.1 KB)
This should work.

I believe the problem was the qPerfectionWeld. I was able to get the animation to work without the backwards tool grip, but it was a different rotation than in the animation in the animation editor. This time it is because the animation wasn’t playing on the handle. You should try take a look at: How to animate Tool Parts (Guns, Knifes etc.). I think this would help.

Here is the studio file to the “improved” battering ram:
Ram.rbxm (60.3 KB)

Still comes out for the same issue with me.

So, I’ll reanimate it, trying to fix that.
How can I make the handle not start off this way?

Anyone help on my new post? Even rotation didn’t seem to help.

I wish I could help some more, but this issue has gone out of my skill range and I honestly have no clue what is going on. I hope you can figure it out!