Tool idle animation broken

Hello, I made an Idle animation for a tool and it seems to be a bit broken, if I’m not wrong…

How should it be:

The broken:


What you need to do is go to the settings of the place and change the animation settings to Set by Developer instead of Player choice. This happened with my walking animation and that fixed it, so the same might work for you. Nothing is broken with your animation, it’s just that the player chosen tool animation overrides your tool animation.

1 Like

Set the animation priority to action so no other animations (Like the tool holding animation) overlap it.


I answered something like this a while ago. Trying to Make Character Body Part Positioning - #5 by Inkthirsty

1 Like

Do you mean this?

Captura de pantalla 2020-09-22 a las 22.42.27

Yes. Change it to standard and it should work.

It didn’t work, but I think I know why. You said it worked for your walking animation, so maybe you didn’t put it for the tool. I don’t know if I’m wrong, but if I am, correct me please. Thank you.

It worked, thank you, but the tool keeps being held in the right hand when the tool is supposed to be held in the left hand like before. Look how it looks:

Captura de pantalla 2020-09-23 a las 7.13.54

So is there a way to change the tool position?

Get a tool grip editor plugin. Many of them are viruses, here’s a safe one.

1 Like

Thank you so much! I didn’t remember to use a plugin I had for the tool grip.