Tool Motor6D Animation Issues

Hello there,

This is my first time experimenting around tool animations + Motor6Ds. I’m running into some issues and I’ve tried many different approaches and it still doesn’t work.

On the animation editor, the sword stays where it should, maintaining within the character’s hands.

In contrast to animation editor, the playtest session demonstrates different results

Sometimes the sword works, sometimes it doesn’t, does any one know any work arounds?

I see that you’ve motor6d’d the handle to the rig to be able to animate. But have you added a script that would weld the handle to the character’s rig so that the animation can play properly?

To me it looks like you scripted a motor6d to attach But you placed it in the torso and not the Right Arm like you had in the rig you were animating.Purely speculation but please explain how you attach the motor6d and I might be able to help.

Hey, I’ve made my own script to convert any Welds created by the tool to be made into Motor6Ds. Also, I believe you think that everything is related to the Torso due to the way Moon Animator displays the rig, but the Motor6D is related to the Right Arm.

This piece of code is what handles the Motor6D conversion.

	if object:IsA("Tool") then
		hasTool = true
	if object:IsA("Weld") and hasTool then
		local new ="Motor6D", object.Parent)
		new.Part0 = object.Part0
		new.Part1 = object.Part1 
		new.C1 = object.C1
		new.C0 = object.C0
		new.Name = "Custom_"..object.Name
		table.insert(temps, new)