Tool's local scripts not working after the tool is cloned to the backpack

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I want the tool to clone to the backpack with the local script working

  2. What is the issue? Include screenshots / videos if possible!
    cloning the tool makes the local

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    i tried firing a remote event when the script runs but the local script didn’t even detect the remote event and all the other solutions are for server scripts not working or they don’t have a solution yet

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!
the console should print: “equipped tool” but it doesn’t

script to insert the tool into the player’s backpack

	local value = plr.Weapon --Weapon is a string value in the player
	value.Value = script.Parent.Value.Value
	if value.Value == "Ultrakill" then
		local tool = game.ReplicatedStorage.Weapons.Ultrakill:Clone()
		tool.Parent = plr.Backpack
1 Like

I removed a line of code in the tool that waits for the character to load

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.