Tools not working after update

didn’t know what topic to put this in, please tell me where it goes.

The tools in my game broke.

But I just made an update, before that update the tools worked just fine. Till I don’t know what the hell even happened! I updated the game once and on that day it worked. The next day I joined, bam the tools don’t even work! Even when I push the left mouse button they still dont do a single damn thing!

What is even happening, My game is ruined now and I absolutely hate spending another 2 hours of my time!

1 Like

We don’t know what you even updated. First off let me say this and for EVERYONE reading:


Make a local file or another test game for updates! Do NOT update the original game unless everrything works!!


What you updated? Try to revert the place files at `Configure Place > Version History.
This would be the best option you can do.

I did convert versions. I updated to the recent update yesterday and they did work yesterday. All I updated was just 1 part of a building I was making. This is really pissing me off because I NEED everything in this game to work. I don’t know what the game’s problem is, but it is definitely 100% uncurable.

I made no more updates than the one yesterday. Its starting to get too illogical and I looked through my game for a single virus and never ever found one. Does anyone here know what is even happening or am I just helpless and have to abandon one of the most important things I need to make?

Can you try to update to the version of 2 days ago? If that can’t be done, atleast try to revert or download to the version that is the closest to the update you released. I know this is pissing you off but I am trying my best, this never happened to me.

But… I added significant stuff and that would take over 20+ minutes to rebuild all that. The one from 2 days ago was just an empty baseplate without those shitty tools. I know they will still break and its pretty annoying on why studio does this stupid crap.

I don’t know. Try all of the versions that you have and one by one test them. Nothing else cannot be done and nobody, even Roblox, can’t help you more.

Well I tried reverting to versions, the damn game is still getting crappy with me. I guess this is the end of what I worked on and put so much effort and time into. This doesn’t do it with other games and it’s annoying and I will try my best not to destroy my entire creation after doing this. These tools HAVE to work for my game to not get at least 20K+ dislikes.

I guess you can do a very crappy (but useful) thing here. Ah. I hate to say it but, you now have to make a new game, copy and paste the scripts from your original game and check VERY CLOSELY the scripts, for no errors. Good luck on that.